summaryrefslogtreecommitdiffstats
path: root/desktop/gtk-chtheme/gtk-chtheme.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/gtk-chtheme/gtk-chtheme.SlackBuild')
-rw-r--r--desktop/gtk-chtheme/gtk-chtheme.SlackBuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/desktop/gtk-chtheme/gtk-chtheme.SlackBuild b/desktop/gtk-chtheme/gtk-chtheme.SlackBuild
index 190f73b84a..d96334b396 100644
--- a/desktop/gtk-chtheme/gtk-chtheme.SlackBuild
+++ b/desktop/gtk-chtheme/gtk-chtheme.SlackBuild
@@ -50,6 +50,8 @@ if [ "$ARCH" = "i486" ]; then
sed -i 's#CFLAGS += -Wall#CFLAGS += -O2 -march=i486 -mtune=i686#' $TMP/$PRGNAM-$VERSION/Makefile
elif [ "$ARCH" = "i686" ]; then
sed -i 's#CFLAGS += -Wall#CFLAGS += -O2 -march=i686 -mtune=i686#' $TMP/$PRGNAM-$VERSION/Makefile
+elif [ "$ARCH" = "x86_64" ]; then
+ sed -i 's#CFLAGS += -Wall#CFLAGS += -O2 -fPIC#' $TMP/$PRGNAM-$VERSION/Makefile
fi
make || exit 1
@@ -73,4 +75,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}