summaryrefslogtreecommitdiffstats
path: root/desktop/fvwm3/fvwm3.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/fvwm3/fvwm3.SlackBuild')
-rw-r--r--desktop/fvwm3/fvwm3.SlackBuild32
1 files changed, 21 insertions, 11 deletions
diff --git a/desktop/fvwm3/fvwm3.SlackBuild b/desktop/fvwm3/fvwm3.SlackBuild
index 06a22b0a11..73f5b0d69e 100644
--- a/desktop/fvwm3/fvwm3.SlackBuild
+++ b/desktop/fvwm3/fvwm3.SlackBuild
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=fvwm3
-VERSION=${VERSION:-1.0.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.0.2}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -63,6 +63,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
+patch -p1 < $CWD/update_fvwm_screen-dont_lose_desk_from_StartsOnScreen.patch
+
sed -i '/^@FVWM_BUILD_GOLANG_TRUE@GOBUILD = $(GOCMD) build/s/$/ -mod=vendor/' \
bin/FvwmPrompt/Makefile.in
@@ -127,24 +129,32 @@ zcat $CWD/xinitrc.fvwm3.gz > $PKG/etc/X11/xinit/xinitrc.fvwm3
chmod 755 $PKG/etc/X11/xinit/xinitrc.fvwm3
rm -rf $PKG/usr/share/doc
-
rm -rf $PKG/usr/share/locale
+rm -f $PKG/usr/bin/fvwm3-convert-2.6
+mv $PKG/usr/bin/FvwmCommand $PKG/usr/bin/Fvwm3Command
+mv $PKG/usr/bin/xpmroot $PKG/usr/bin/xpmroot3
-rm -rf $PKG/usr/bin/fvwm3-convert-2.6
-rm -rf $PKG/usr/man/man1/fvwm3-convert-2.6.1.gz
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mv $PKG/usr/bin/xpmroot $PKG/usr/bin/xpmroot3
-mv $PKG/usr/man/man1/xpmroot.1 $PKG/usr/man/man1/xpmroot3.1
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
for m in $PKG/usr/man/man1/Fvwm* ; do
+ case "$m" in *FvwmPrompt*) continue ;; esac
mv $m ${m/Fvwm/Fvwm3}
done
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+for m in $PKG/usr/man/man1/fvwm-* ; do
+ mv $m ${m/fvwm-/fvwm3-}
+done
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+mv $PKG/usr/man/man1/xpmroot.1.gz $PKG/usr/man/man1/xpmroot3.1.gz
+
+rm -f $PKG/usr/man/man1/fvwm3-convert-2.6.1.gz
+rm -f $PKG/usr/man/man1/fvwm3-config-2.6.1.gz
+rm -f $PKG/usr/man/man1/Fvwm3Console.1.gz
+rm -f $PKG/usr/man/man1/Fvwm3ConsoleC.pl.1.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a NEWS $PKG/usr/doc/$PRGNAM-$VERSION