summaryrefslogtreecommitdiffstats
path: root/desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild')
-rw-r--r--desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild40
1 files changed, 23 insertions, 17 deletions
diff --git a/desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild b/desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild
index 5361c5a825..8c8b68db66 100644
--- a/desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild
+++ b/desktop/ffmpegthumbnailer/ffmpegthumbnailer.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for FFmpegthumbnailer
# Copyright 2007-2009 Frank Caraballo <fecaraballo{at}gmail{dot}com>
-# Copyright 2012-2014 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2012-2015 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=ffmpegthumbnailer
-VERSION=${VERSION:-2.0.9}
+VERSION=${VERSION:-2.0.10}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,21 +70,27 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib$LIBDIRSUFFIX \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --enable-static=no \
- --enable-gio \
- --enable-thumbnailer \
- --build=$ARCH-slackware-linux
-
-make
-make install-strip DESTDIR=$PKG
+# Fix installing into correct libdir
+sed -i "s|\${CMAKE_INSTALL_PREFIX}/lib|\${CMAKE_INSTALL_PREFIX}/lib\${LIB_SUFFIX}|g" \
+ CMakeLists.txt
+
+mkdir build
+cd build
+ cmake \
+ -DCMAKE_CXX_FLAGS="${SLKCFLAGS}" \
+ -DCMAKE_C_FLAGS="${SLKCFLAGS}" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DENABLE_GIO="yes" \
+ -DENABLE_THUMBNAILER="yes" \
+ ..
+
+ make VERBOSE=1
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done