summaryrefslogtreecommitdiffstats
path: root/desktop/ccsm/ccsm.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/ccsm/ccsm.SlackBuild')
-rw-r--r--desktop/ccsm/ccsm.SlackBuild22
1 files changed, 10 insertions, 12 deletions
diff --git a/desktop/ccsm/ccsm.SlackBuild b/desktop/ccsm/ccsm.SlackBuild
index 381e4159ff..800216deed 100644
--- a/desktop/ccsm/ccsm.SlackBuild
+++ b/desktop/ccsm/ccsm.SlackBuild
@@ -5,7 +5,7 @@
# Written by M.Dinslage (daedra1980@gmail.com)
PRGNAM=ccsm
-VERSION=${VERSION:-0.8.4}
+VERSION=${VERSION:-0.8.10}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -41,25 +41,23 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM
+tar xvf $CWD/$PRGNAM.tar.gz
+cd $PRGNAM
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --prefix=/usr --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS COPYING* ChangeLog INSTALL NEWS README* TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING* INSTALL $PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh