summaryrefslogtreecommitdiffstats
path: root/business/ledger/CMakeLists.txt.patch
diff options
context:
space:
mode:
Diffstat (limited to 'business/ledger/CMakeLists.txt.patch')
-rw-r--r--business/ledger/CMakeLists.txt.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/business/ledger/CMakeLists.txt.patch b/business/ledger/CMakeLists.txt.patch
new file mode 100644
index 0000000000..2f292ffb81
--- /dev/null
+++ b/business/ledger/CMakeLists.txt.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 15cb7ef90..bb8bfa2dc 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -12,7 +12,7 @@ set(Ledger_TEST_TIMEZONE "America/Chicago")
+
+ # Point CMake at any custom modules we may ship
+ list(APPEND CMAKE_MODULE_PATH "${PROJECT_SOURCE_DIR}/cmake")
+-if(${CMAKE_VERSION} VERSION_LESS "3.16.0")
++if ((${CMAKE_VERSION} VERSION_GREATER_EQUAL "3.7.0") AND (${CMAKE_VERSION} VERSION_LESS "3.16.0"))
+ # use backported module from 3.15 (introduced 3.12) to support older versions of cmake
+ list(APPEND CMAKE_MODULE_PATH "${PROJECT_SOURCE_DIR}/cmake/python-backport")
+ endif() \ No newline at end of file