summaryrefslogtreecommitdiffstats
path: root/audio/wmusic/wmusic.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/wmusic/wmusic.SlackBuild')
-rw-r--r--audio/wmusic/wmusic.SlackBuild45
1 files changed, 25 insertions, 20 deletions
diff --git a/audio/wmusic/wmusic.SlackBuild b/audio/wmusic/wmusic.SlackBuild
index 46de480ff5..e3b032c518 100644
--- a/audio/wmusic/wmusic.SlackBuild
+++ b/audio/wmusic/wmusic.SlackBuild
@@ -27,6 +27,8 @@
# Currently maintained by B. Watson <yalhcru@gmail.com>
+# 20180916 bkw: update for v2.0.0.
+
# 20160816 bkw:
# - take over maintenance
# - BUILD=2
@@ -35,8 +37,8 @@
# - remove 'see the Info files' from man page, as there is no info file.
PRGNAM=wmusic
-VERSION=${VERSION:-1.5.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.0.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -75,28 +77,31 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# ./configure ignores CFLAGS, hence the sed stuff. -include string.h
-# kills a couple of warnings.
-./configure
-sed -i "s,-g -O2,$SLKCFLAGS -include string.h," src/Makefile
-make
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# 'make install' ignores DESTDIR, it's only 1 file anyway.
-mkdir -p $PKG/usr/bin
-install -s -m0755 src/wmusic $PKG/usr/bin
+# Stop spewing these:
+# GLib-GObject-CRITICAL **: g_object_get: assertion 'G_IS_OBJECT (object)' failed
+patch -p1 < $CWD/kill_glib_assertion_spam.diff
-mkdir -p $PKG/usr/man/man1
-sed '/see the Info files/d' debian/$PRGNAM.1 | \
- gzip -9c > $PKG/usr/man/man1/$PRGNAM.1.gz
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+sed -i '/see the Info files/d' $PRGNAM.1
+make install-strip DESTDIR=$PKG
+gzip -9 $PKG/usr/man/man1/$PRGNAM.1
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README COPYING ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install