summaryrefslogtreecommitdiffstats
path: root/audio/pithos/pithos.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/pithos/pithos.SlackBuild')
-rw-r--r--audio/pithos/pithos.SlackBuild32
1 files changed, 21 insertions, 11 deletions
diff --git a/audio/pithos/pithos.SlackBuild b/audio/pithos/pithos.SlackBuild
index 32579cffe5..0d7c1f9b1e 100644
--- a/audio/pithos/pithos.SlackBuild
+++ b/audio/pithos/pithos.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pithos
-# Copyright 2013 Robby Workman, Northport, Alabama, USA
+# Copyright 2013,2017 Robby Workman, Tuscaloosa, Alabama, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pithos
-VERSION=${VERSION:-git_ed501485}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.4.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -61,15 +61,25 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
+chown -R root:root $PRGNAM-$VERSION
+find -L $PRGNAM-$VERSION \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+mkdir -p $PRGNAM-$VERSION/build
+meson \
+ --prefix=/usr \
+ --libdir=/usr/lib64 \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ $PRGNAM-$VERSION \
+ $PRGNAM-$VERSION/build
+
+DESTDIR=$PKG ninja -C $PRGNAM-$VERSION/build install
cat $CWD/contrib/pithosctl > $PKG/usr/bin/pithosctl
chmod 0755 $PKG/usr/bin/pithosctl
@@ -78,7 +88,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGELOG README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $PRGNAM-$VERSION/README.md $PRGNAM-$VERSION/license $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install