summaryrefslogtreecommitdiffstats
path: root/audio/faac/faac.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/faac/faac.SlackBuild')
-rw-r--r--audio/faac/faac.SlackBuild23
1 files changed, 16 insertions, 7 deletions
diff --git a/audio/faac/faac.SlackBuild b/audio/faac/faac.SlackBuild
index 279532655d..cd022d7932 100644
--- a/audio/faac/faac.SlackBuild
+++ b/audio/faac/faac.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Slackware build script for faac
+# Slackware build script for faac
# Copyright (c) 2008, Antonio Hernández Blas <hba.nihilismus@gmail.com>
# All rights reserved.
@@ -27,7 +27,7 @@
PRGNAM=faac
VERSION=${VERSION:-1.28}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
@@ -70,7 +70,7 @@ fi
# desired result in every case *except* where one wants to use the internal
# implementation, and that creates other problems, so we don't support it.
#
-# From what used to be in our README:
+# From what used to be in our README:
# faac comes with its own version of libmp4v2, but if you use it, you have to
# uninstall faac everytime you want to update it, as faac would otherwise
# detect the already installed libmp4v2 and build against it. Then, when you
@@ -93,6 +93,17 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# http://lists.slackbuilds.org/pipermail/slackbuilds-users/2010-May/005680.html
+# Fix compilation problem faac-1.28 and external libmp4v2 1.9.1
+# see http://sourceforge.net/tracker/?func=detail&aid=2894310&group_id=704&atid=100704
+# and http://ftp.eenet.ee/gentoo-portage/media-libs/faac/files/faac-1.28-external-libmp4v2.patch
+patch -p1 < $CWD/faac-1.28-external-libmp4v2.patch
+# having just patched configure.in, we need to bludgeon automake
+libtoolize --force --copy
+aclocal
+autoconf
+automake --add-missing
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -107,10 +118,8 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install-strip DESTDIR=$PKG
-( cd $PKG/usr/man || exit 1
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $(find $PKG/usr/man -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS ChangeLog COPYING INSTALL NEWS README TODO docs/* \