summaryrefslogtreecommitdiffstats
path: root/audio/clxclient/clxclient.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/clxclient/clxclient.SlackBuild')
-rw-r--r--audio/clxclient/clxclient.SlackBuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/audio/clxclient/clxclient.SlackBuild b/audio/clxclient/clxclient.SlackBuild
index 0bbd328156..4d132c9d63 100644
--- a/audio/clxclient/clxclient.SlackBuild
+++ b/audio/clxclient/clxclient.SlackBuild
@@ -3,7 +3,7 @@
# Written by Michales Michaloudes korgie@gmail.com
PRGNAM=clxclient
-VERSION=${VERSION:-3.6.1}
+VERSION=${VERSION:-3.9.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -44,10 +44,10 @@ tar -xjvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
sed -i -e 's+/usr/local+/usr+' $TMP/$PRGNAM-$VERSION/Makefile
@@ -63,7 +63,7 @@ install -m 755 lib$PRGNAM.so.$VERSION $PKG/usr/lib${LIBDIRSUFFIX}
cd $PKG/usr/lib${LIBDIRSUFFIX}
ln -s ./lib$PRGNAM.so.$VERSION lib$PRGNAM.so
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
cd $TMP/$PRGNAM-$VERSION