summaryrefslogtreecommitdiffstats
path: root/academic/xephem/xephem.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/xephem/xephem.SlackBuild')
-rw-r--r--academic/xephem/xephem.SlackBuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/academic/xephem/xephem.SlackBuild b/academic/xephem/xephem.SlackBuild
index df55b1e191..f0aabfd1b1 100644
--- a/academic/xephem/xephem.SlackBuild
+++ b/academic/xephem/xephem.SlackBuild
@@ -5,16 +5,14 @@
# Written by Dario Nicodemi dario.sbo@gmail.com
PRGNAM=xephem
-VERSION=${VERSION:-3.7.5}
+VERSION=${VERSION:-3.7.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -22,7 +20,7 @@ fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp} # Drop the package in /tmp
+OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
@@ -38,7 +36,7 @@ else
LIBDIRSUFFIX=""
fi
-set -e # Exit on most errors
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -47,11 +45,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
sed -i 's/^CFLAGS=/override CFLAGS+=/g' libip/Makefile
sed -i 's/^CFLAGS =/override CFLAGS +=/g' libpng/Makefile