summaryrefslogtreecommitdiffstats
path: root/academic/pyCRAC
diff options
context:
space:
mode:
Diffstat (limited to 'academic/pyCRAC')
-rw-r--r--academic/pyCRAC/README24
-rw-r--r--academic/pyCRAC/pyCRAC.SlackBuild18
-rw-r--r--academic/pyCRAC/pyCRAC.info12
-rw-r--r--academic/pyCRAC/setup_slack.py6
4 files changed, 13 insertions, 47 deletions
diff --git a/academic/pyCRAC/README b/academic/pyCRAC/README
index 9eb56fc043..b9b74fd37b 100644
--- a/academic/pyCRAC/README
+++ b/academic/pyCRAC/README
@@ -5,8 +5,10 @@ data generated by CLIP or CRAC protocols).
It can be used to remove duplicate reads,tackles directional libraries
and reports sense and anti-sense hits.
-Included is the pipeline used for the analysis of a group of CRAC data
-sets.
+A pipeline that streamlines the analysis of a group of CRAC datasets
+is available at https://git.ecdf.ed.ac.uk/sgrannem/crac_pipelines and
+depends on the python package 'ruffus', also at slackbuilds.org.
+
References
@@ -23,21 +25,3 @@ A, Langford A, Franklin R, Iosub I, Wadsworth P, Sanguinetti G,
Granneman S.
If you want to run the test suite after installation, see README.tests.
-
-
-Note on the Crac pipelines:
-
-Use the -h flag to get a detailed help menu.
-
-The CRAC_pipeline_PE.py script needs to be run from the folder that
-contains the fastq files
-
-The barcode list file should contain two tab-separated columns in which
-the first column is the barcode sequence and the second column is the
-name of the experiment
-
-The file containing the adapter sequences should be in the fasta format.
-
-The chromosome_lengths file should contain two tab-separated columns in
-which the first column has the chromosome name and the second the
-chromosome length.
diff --git a/academic/pyCRAC/pyCRAC.SlackBuild b/academic/pyCRAC/pyCRAC.SlackBuild
index 51f54e1913..038db738b1 100644
--- a/academic/pyCRAC/pyCRAC.SlackBuild
+++ b/academic/pyCRAC/pyCRAC.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyCRAC
-# Copyright 2017-2021 Rob van Nues
+# Copyright 2017-2023 Rob van Nues
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,15 +25,11 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pyCRAC
-VERSION=${VERSION:-1.5.1}
+VERSION=${VERSION:-1.5.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-PIPENAM=crac_pipelines
-PIPEVER=master
-#PIPETAG=sgrann
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -74,18 +70,9 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-#rm -rf $PIPETAG-$PIPENAM-$PIPEVER
-rm -rf $PIPENAM-$PIPEVER
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
-mkdir $PRGNAM/$PIPENAM
-
-if [[ -f $CWD/$PIPENAM-$PIPEVER.tar.gz ]]; then
- tar xvf $CWD/$PIPENAM-$PIPEVER.tar.gz -C $PRGNAM/$PIPENAM --strip-components=1
-else
- echo "$PIPENAM-$PIPEVER.tar.gz not found"
-fi
#replace setup.py; test.sh
mv setup.py setup.py.ORIG
@@ -114,7 +101,6 @@ cp -a \
$CWD/README.tests $CWD/setup_slack.py \
$CWD/README \
$PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $PRGNAM/$PIPENAM/README.md $PKG/usr/doc/$PRGNAM-$VERSION/$PIPENAM-README.md
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/academic/pyCRAC/pyCRAC.info b/academic/pyCRAC/pyCRAC.info
index 872cf0be27..8fcdeffd60 100644
--- a/academic/pyCRAC/pyCRAC.info
+++ b/academic/pyCRAC/pyCRAC.info
@@ -1,12 +1,10 @@
PRGNAM="pyCRAC"
-VERSION="1.5.1"
-HOMEPAGE="http://sandergranneman.bio.ed.ac.uk/pycrac-software"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pyCRAC/pyCRAC-1.5.1.tar.gz \
- https://git.ecdf.ed.ac.uk/sgrannem/crac_pipelines/-/archive/master/crac_pipelines-master.tar.gz"
-MD5SUM="f634167e03ef26213efb4400671dbc9c \
- ab1f71f1d38096af86048866c0bbd3d8"
+VERSION="1.5.2"
+HOMEPAGE="https://git.ecdf.ed.ac.uk/sgrannem/pycrac"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pyCRAC/pyCRAC-1.5.2.tar.gz"
+MD5SUM="f2bbb5dbcbe2b17051b8843a7e4d519f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="flexbar novocraft numpy3 pysam scipy3 pandas ruffus"
+REQUIRES="flexbar novocraft pysam python3-scipy python3-pandas"
MAINTAINER="Rob van Nues"
EMAIL="sborg63@disroot.org"
diff --git a/academic/pyCRAC/setup_slack.py b/academic/pyCRAC/setup_slack.py
index 0340228e84..db5c30751f 100644
--- a/academic/pyCRAC/setup_slack.py
+++ b/academic/pyCRAC/setup_slack.py
@@ -2,7 +2,7 @@
__author__ = "Sander Granneman"
__copyright__ = "Copyright 2021"
-__version__ = "1.5.1"
+__version__ = "1.5.2"
__credits__ = ["Sander Granneman","Grzegorz Kudla","Hywell Dunn Davies"]
__maintainer__ = ["Sander Granneman","Rob van Nues for SlackBuilds.org"]
__email__ = ["sgrannem@staffmail.ed.ac.uk", "sborg63@disroot.org"]
@@ -25,7 +25,7 @@ setup(name='pyCRAC',
description='Python NextGen sequencing data processing software',
author='Sander Granneman',
author_email='sgrannem@staffmail.ed.ac.uk',
- url='http://sandergranneman.bio.ed.ac.uk/Granneman_Lab/pyCRAC_software.html',
+ url='https://git.ecdf.ed.ac.uk/sgrannem/pycrac',
packages=['pyCRAC','pyCRAC.Parsers','pyCRAC.Classes','pyCRAC.Methods'],
install_requires=['numpy >= 1.5.1', 'cython >=0.19', 'pysam >= 0.6','six >= 1.9.0'],
scripts=[
@@ -55,8 +55,6 @@ setup(name='pyCRAC',
'pyCRAC/scripts/pyGTF2bedGraph.py',
'pyCRAC/scripts/pyFilterGTF.py',
'pyCRAC/scripts/pyNormalizeIntervalLengths.py',
- 'pyCRAC/crac_pipelines/CRAC_pipeline_PE.py',
- 'pyCRAC/crac_pipelines/CRAC_pipeline_SE.py',
],
classifiers=[ 'Development Status :: 5 - Production/Stable',
'Environment :: Console',