summaryrefslogtreecommitdiffstats
path: root/academic/pianobooster
diff options
context:
space:
mode:
Diffstat (limited to 'academic/pianobooster')
-rw-r--r--academic/pianobooster/pianobooster.SlackBuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/academic/pianobooster/pianobooster.SlackBuild b/academic/pianobooster/pianobooster.SlackBuild
index d8af17f95f..db36beccaf 100644
--- a/academic/pianobooster/pianobooster.SlackBuild
+++ b/academic/pianobooster/pianobooster.SlackBuild
@@ -3,10 +3,11 @@
# Slackware build script for pianobooster
# Written by B. Watson (yalhcru@gmail.com)
+# Modified by Willy Sudiarto Raharjo <willysr@slackware-id.org>
PRGNAM=pianobooster
VERSION=${VERSION:-0.6.4b}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -51,12 +52,19 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# remove unneeded flag
+ sed -i '/mwindows/d' src/CMakeLists.txt
+
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release ../src
+
+ # DSO GL and pthread fix
+ sed -i "s/$/-lGL -lpthread/" CMakeFiles/pianobooster.dir/link.txt
+
make VERBOSE=1
make install/strip DESTDIR=$PKG
cd ..