summaryrefslogtreecommitdiffstats
path: root/academic/avl/Makefile_patches/Makefile.avl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'academic/avl/Makefile_patches/Makefile.avl.patch')
-rw-r--r--academic/avl/Makefile_patches/Makefile.avl.patch130
1 files changed, 62 insertions, 68 deletions
diff --git a/academic/avl/Makefile_patches/Makefile.avl.patch b/academic/avl/Makefile_patches/Makefile.avl.patch
index 72f218e36d..2b2a1090cb 100644
--- a/academic/avl/Makefile_patches/Makefile.avl.patch
+++ b/academic/avl/Makefile_patches/Makefile.avl.patch
@@ -1,32 +1,36 @@
---- bin/Makefile 2013-10-06 19:34:54.000000000 -0400
-+++ bin/Makefile.avl 2016-09-27 21:49:02.000000000 -0400
-@@ -2,8 +2,7 @@
- # Makefile for AVL
+--- bin/Makefile.gfortran 2017-02-12 14:25:41.000000000 -0500
++++ bin/Makefile.gfortran.new 2017-04-12 12:51:21.829538710 -0400
+@@ -3,9 +3,7 @@
+ # H.Youngren 2/8/17
#
+-#BINDIR = .
-BINDIR = /home/codes/bin/
-INSTALLCMD = install -s
+BINDIR = $(DESTDIR)/usr/bin/
SRC = ../src
-@@ -18,92 +17,27 @@
- matrix.o spline.o sgutil.o \
+@@ -21,85 +19,24 @@
second.o
+ # libraries needed
-PLTOBJ = ../plotlib/libPlt.a
-EIGOBJ = ../eispack/eispack.a
--## EIGOBJ = eispack.o
--
++PLTOBJ = ../plotlib/libPlt_gDP.a
++EIGOBJ = ../eispack/eispack_gDP.a
+ ## EIGOBJ = eispack.o
+
-###================================================
-### Default compilers and flags
-FC = f77
-FFLAGS = -O
+-DP =
+-DBG =
+-LFLG =
+-
-PLTLIB = -lX11
-FTNLIB =
-+PLTOBJ = ../plotlib/libPlt_gDP.a
-+EIGOBJ = ../eispack/eispack_gDP.a
-
-#Subroutine SECOND source file
-SECOND = second_g77.f
-
@@ -34,90 +38,80 @@
-
-# Uncomment flags for desired machine...
-
+-
-##--------------------------
--### DEC Alpha with OSF and DEC f77/f90 compiler
--#FC = f77
--#FFLAGS = -fast -O4 -tune host
--##--------------------------
--### SGI setup
--#FC = f77
--#FFLAGS = -O2
--##--------------------------
--## Uncomment for RS/6000
--#FFLAGS = -O -qextname
--##--------------------------
--## Uncomment for HP-9000
--#FFLAGS = -O +ppu
--#FTNLIB = -U77
--##--------------------------
--### Absoft Linux f77
--#FC = f77
--#FFLAGS = -O -f -s -W -B108 -N34
--##--------------------------
--### f2c/gcc compiler driver
--#FC = fort77
--#FFLAGS = -O2 -fomit-frame-pointer
--##--------------------------
--### GNU g77
--#FC = g77
--#FFLAGS = -O3
--##--------------------------
--### Intel Fortran Compiler 8.x
--FC = ifort
--FFLAGS = -O
--PLTLIB = -L/usr/X11R6/lib -lX11
--SECOND = second_ifc.f
+-### Intel Fortran Compiler
+-#FC = ifort
+-#OPT = -O
+-##OPT = -O0 -g
+-#ACHK =
+-#PLTLIB = -L/usr/X11R6/lib -lX11
+-#SECOND = second_ifc.f
-#FTNLIB = -Vaxlib
+-#PLTOBJ = ../plotlib/libPlt.a
+-#EIGOBJ = ../eispack/libeispack.a
+-#DP =
-##--------------------------
--### double-precision option (also need double precision Eispack and libPlt)
--FFLAGS = -O -r8
--PLTOBJ = ../plotlib/libPltDP.a
+-### double-precision (also need double precision eispack and libPlt)
+-#DP = -r8
+-#PLTOBJ = ../plotlib/libPltDP.a
+-#FFLAGS = $(OPT) $(ACHK) $(DP)
+-
-
-##---------------------------------------
--## Uncomment for Mac OSX gfortran
+-## Uncomment for gfortran
++# Compiler and flags
FC = gfortran
-
--ACHK = -fbounds-check -finit-real=inf -ffpe-trap=invalid,zero,denormal
--#ACHK =
+-OPT = -O
+-DP =
+-ACHK =
-
-+#ACHK = -fbounds-check -finit-real=inf -ffpe-trap=invalid,zero,denormal
-+ACHK =
-+PLTLIB=-lX11
-+FTNLIB=
-
--#FTNLIB = -Vaxlib
--FTNLIB =
+-PLTLIB = -L/usr/X11R6/lib -lX11
SECOND = second_g77.f
-
--DP =
+-# debug
+-#OPT = -O0
+-#DBG= -g
+-#ACHK = -fbounds-check -finit-real=inf
+-#ACHK = -fbounds-check -finit-real=inf -ffpe-trap=invalid,zero,denormal
+-
-PLTOBJ = ../plotlib/libPlt_gSP.a
--EIGOBJ = ../eispack/eispack_gSP.a
+-EIGOBJ = ../eispack/libeispack.a
-
+-##--------------------------
+-# double precision (compile appropriate eispack and libPlt)
-#DP = -fdefault-real-8
--#PLTOBJ = ../plotlib/libPltDP.a
--#EIGOBJ = ../eispack/eispack_gDP.a
+-#PLTOBJ = ../plotlib/libPlt_gDP.a
+-#EIGOBJ = ../eispack/libeispackDP.a
+-##--------------------------
-
--FFLAGS = -O -m64 $(ACHK) $(DP)
+-# use -m32 for 32-bit binary, -m64 for 64-bit (check your system!)
+-#FFLAGS = $(OPT) -m32 $(ACHK) $(DP)
+-FFLAGS = $(OPT) -m64 $(ACHK) $(DP)
+-# to make static executable
+-#LFLG = -static
-##---------------------------------------
-
+-
++ACHK =
++PLTLIB=-lX11
++FTNLIB=
+DP = -fdefault-real-8
-
+FFLAGS = -O2 $(ACHK) $(DP)
all: $(PROGS)
install: $(PROGS)
- $(INSTALLCMD) $(PROGS) $(BINDIR)
-+ install -d -m 0755 $(BINDIR)
++ install -d -m 0755 $(BINDIR)
+ install -m 0755 $(PROGS) $(BINDIR)
clean:
-/bin/rm $(PROGS)
-@@ -114,7 +48,6 @@
+@@ -110,7 +47,6 @@
avl: $(AOBJS)
- $(FC) -o avl $(AOBJS) $(ALIBS) $(PLTOBJ) $(EIGOBJ) $(PLTLIB) $(FTNLIB)
+ $(FC) -o avl $(AOBJS) $(ALIBS) $(PLTOBJ) $(EIGOBJ) $(PLTLIB) $(FTNLIB) $(LFLG)
- $(INSTALLCMD) avl $(BINDIR)
dtest: dtest.o
- $(FC) -o dtest dtest.o
+ $(FC) -o dtest dtest.o $(LFLG)