summaryrefslogtreecommitdiffstats
path: root/academic/PhyML/PhyML.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/PhyML/PhyML.SlackBuild')
-rw-r--r--academic/PhyML/PhyML.SlackBuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/academic/PhyML/PhyML.SlackBuild b/academic/PhyML/PhyML.SlackBuild
index 5fb6ce9fcf..05fb80d8cc 100644
--- a/academic/PhyML/PhyML.SlackBuild
+++ b/academic/PhyML/PhyML.SlackBuild
@@ -4,17 +4,19 @@
# Written by Petar Petrov, <ppetrov@paju.oulu.fi> and
# hereby submitted to the public domain
+# Thanks to Niels Horn for the handy modifications and
+# corrections!
+
# THIS SLACKBUILD IS DISTRIBUTETD IN THE HOPE OF BEING
# USEFUL BUT WITHOUT ANY WARRANTY. THE AUTHOR IS _NOT_
# RESPONSIBLE FOR ANY DAMAGE OR DATA LOSS CAUSED BY IT.
PRGNAM=PhyML
-VERSION=${VERSION:-3.0}
+VERSION=${VERSION:-20110526}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
SRCNAM=$(echo $PRGNAM | tr A-Z a-z)
-SRCVER=2010023
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -48,9 +50,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $SRCNAM
-tar xvf $CWD/${SRCNAM}_$SRCVER.tar.gz
-cd $SRCNAM
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -58,9 +60,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-aclocal
-autoconf -f
-automake -f
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
@@ -70,11 +69,13 @@ automake -f
--docdir=/usr/doc/$PRGNAM-$VERSION \
--build=$ARCH-slackware-linux
-#Use our CFLAGS
-sed -i "/^AM_CFLAGS/s/=/+=/" src/Makefile
+# Use our CFLAGS
+sed -i "/^CFLAGS/s/=/+=/" src/Makefile
+sed -i "/^CFLAGS/s/=/+=/" Makefile
-AM_CFLAGS="$SLKCFLAGS" \
- make
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
@@ -82,7 +83,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS ChangeLog COPYING INSTALL \
+ doc/phyml_manual.pdf AUTHORS ChangeLog COPYING INSTALL README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References