summaryrefslogtreecommitdiffstats
path: root/academic/OpenMM/OpenMM.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/OpenMM/OpenMM.SlackBuild')
-rw-r--r--academic/OpenMM/OpenMM.SlackBuild165
1 files changed, 165 insertions, 0 deletions
diff --git a/academic/OpenMM/OpenMM.SlackBuild b/academic/OpenMM/OpenMM.SlackBuild
new file mode 100644
index 0000000000..2696983b1f
--- /dev/null
+++ b/academic/OpenMM/OpenMM.SlackBuild
@@ -0,0 +1,165 @@
+#!/bin/bash
+
+# Slackware build script for OpenMM
+
+# Copyright 2022 William PC - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=OpenMM
+VERSION=${VERSION:-7.7.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=${PRGNAM,,}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# fix library installation path
+# note: the other solution requires less lines,
+# but it was after cmake
+sed -i \
+ -e 's#/lib RUNTIME_DIRECTORY /lib#/lib'${LIBDIRSUFFIX}' RUNTIME_DIRECTORY /lib'${LIBDIRSUFFIX}'#' \
+ -e 's#/lib/plugins RUNTIME_DIRECTORY /lib/plugins#/lib'${LIBDIRSUFFIX}'/plugins RUNTIME_DIRECTORY /lib'${LIBDIRSUFFIX}'/plugins#' \
+ platforms/*/*/CMakeLists.txt \
+ plugins/*/CMakeLists.txt \
+ plugins/*/platforms/*/CMakeLists.txt
+
+sed -i 's#${CMAKE_INSTALL_PREFIX}/lib#&'${LIBDIRSUFFIX}'#' \
+ plugins/*/CMakeLists.txt \
+ plugins/*/platforms/*/CMakeLists.txt \
+ platforms/*/CMakeLists.txt \
+ platforms/*/*/CMakeLists.txt
+
+# fix installation path for examples and licenses
+sed -i 's#\(DESTINATION\) \(examples\)#\1 share/'$PRGNAM'/\2#' \
+ examples/CMakeLists.txt
+sed -i 's#\(DESTINATION\) \(licenses\)#\1 doc/'$PRGNAM-$VERSION'/\2#' \
+ docs-source/CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=ON \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ $OPT_BUILD \
+ -DCMAKE_BUILD_TYPE=Release ..
+
+ # fix installation path of library "libOpenMM.so"
+ sed -i 's#${CMAKE_INSTALL_PREFIX}/lib#&'${LIBDIRSUFFIX}'#' \
+ cmake_install.cmake
+
+ make
+ make install/strip DESTDIR=$PKG
+
+ if [ ${PYTHON:-no} == yes ]; then
+ cd python
+ # require the CFLAGS for linking with the OpenMM libraries
+ CFLAGS="-L$PKG/usr/lib${LIBDIRSUFFIX}" \
+ OPENMM_INCLUDE_PATH="/usr/include;$PKG/usr/include" \
+ OPENMM_LIB_PATH="/usr/lib${LIBDIRSUFFIX};$PKG/usr/lib${LIBDIRSUFFIX}" \
+ python3 setup.py install --root=$PKG
+ # remove temporary folder from python module library path
+ PYVER=$( python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])' )
+ sed -i 's#;'$PKG'/usr/lib'${LIBDIRSUFFIX}'##' $PKG/usr/lib${LIBDIRSUFFIX}/python$PYVER/site-packages/openmm/version.py
+ cd ..
+ fi
+cd ..
+
+# update example's makefile
+sed -i \
+ -e '21s#/usr/local/openmm#/usr#' \
+ -e '31s#/lib#&'${LIBDIRSUFFIX}'#' \
+ $PKG/usr/share/$PRGNAM/examples/Makefile
+
+# prune empty dirc "usr/docs"
+rm -fr $PKG/usr/docs
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ {CODE_OF_CONDUCT,CONTRIBUTING,SUPPORT}.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE