summaryrefslogtreecommitdiffstats
path: root/academic/FreeFem/FreeFem.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/FreeFem/FreeFem.SlackBuild')
-rw-r--r--academic/FreeFem/FreeFem.SlackBuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/academic/FreeFem/FreeFem.SlackBuild b/academic/FreeFem/FreeFem.SlackBuild
index 35ce05e04b..982341fdae 100644
--- a/academic/FreeFem/FreeFem.SlackBuild
+++ b/academic/FreeFem/FreeFem.SlackBuild
@@ -1,9 +1,9 @@
#!/bin/bash
# Slackware build script for FreeFem
-# Based on the Slackware 14.2 SlackBuild and on PKGBUILD script for freefem from AUR
+# Based on the Slackware 15.0 SlackBuild and on PKGBUILD script for freefem from AUR
#
-# Copyright 2019-2022, Fellype do Nascimento, Campinas - Brazil
+# Copyright 2019-2023, Fellype do Nascimento, Guaratinguetá - Brazil
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,11 +26,11 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=FreeFem
-VERSION=${VERSION:-4.11}
+VERSION=${VERSION:-4.14}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-SRCVER=${SRCVER:-4.11}
+SRCVER=${SRCVER:-4.14}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -84,33 +84,30 @@ cp $CWD/tetgen1.5.1-beta1.tar.gz 3rdparty/pkg
autoreconf -i
./configure \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
--prefix=/usr \
--sysconfdir=/etc \
--disable-mumps \
- --with-petsc=/usr/lib${LIBDIRSUFFIX}/petsc/conf/petscvariables \
--with-mpi=/usr/bin/mpic++ \
--enable-hpddm \
--enable-opengl
find . -name Makefile -exec sed -i 's+^gcc+gcc =+' {} \;
find . -name Makefile -exec sed -i 's+^dir+dir =+' {} \;
+find . -name Makefile -exec sed -i "s:/usr/lib/ff++/:/usr/lib${LIBDIRSUFFIX}/ff++/:" {} \;
-## TODO: Enable mumps - FreeFem fails to compile with this option enabled up to now
+## TODO: Enable mumps
make
make install DESTDIR=$PKG
-if [ "$ARCH" = "x86_64" ]; then
- mv $PKG/usr/lib $PKG/usr/lib${LIBDIRSUFFIX}
-fi
-
find "$PKG"/usr/lib${LIBDIRSUFFIX}/ff++/ -name "*.h" -exec chmod o+r {} \;
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS CHANGELOG.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGELOG.md LICENSE.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install