summaryrefslogtreecommitdiffstats
path: root/academic/DRAMPower
diff options
context:
space:
mode:
Diffstat (limited to 'academic/DRAMPower')
-rw-r--r--academic/DRAMPower/DRAMPower.SlackBuild148
-rw-r--r--academic/DRAMPower/DRAMPower.info12
-rw-r--r--academic/DRAMPower/README29
-rw-r--r--academic/DRAMPower/slack-desc19
4 files changed, 208 insertions, 0 deletions
diff --git a/academic/DRAMPower/DRAMPower.SlackBuild b/academic/DRAMPower/DRAMPower.SlackBuild
new file mode 100644
index 0000000000..0d8b89966a
--- /dev/null
+++ b/academic/DRAMPower/DRAMPower.SlackBuild
@@ -0,0 +1,148 @@
+#!/bin/bash
+
+# Slackware build script for DRAMPower
+
+# Copyright 2022 William PC - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=DRAMPower
+VERSION=${VERSION:-4.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+TRACES_COMMIT=e640d3f7ff3766cdf4a799943f81e6ffe0946fb4
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+# correct the path for xerces-c library
+sed -i '89s#lib#&'${LIBDIRSUFFIX}'#' Makefile
+
+# disable downloading traces file
+sed -i '127,128s/^/#/' Makefile
+
+# fix for unpacking traces
+sed -i '131s/^/#/' Makefile
+sed -i '131a\\tmkdir -p traces && unzip -j -d traces traces.zip' Makefile
+
+# fix example makefile
+sed -i 's#DRAMPOWER_PATH ?=.*#DRAMPOWER_PATH ?= /usr/share/'$PRGNAM-$VERSION'#' test/libdrampowertest/Makefile
+sed -i 's/MYPATH :=.*/MYPATH := ./' test/libdrampowertest/Makefile
+sed -i '72,73s#-iquote ${DRAMPOWER_PATH}/src ##' test/libdrampowertest/Makefile
+sed -i '72,73s#-L${DRAMPOWER_PATH}/src/ ##' test/libdrampowertest/Makefile
+sed -i '72,73s#$# -I/usr/include/libdrampower#' test/libdrampowertest/Makefile
+
+sed -i -e 's/test: all/test: $(BINARY) $(BINARY2)/' \
+ -e 's/all:/all: $(BINARY) $(BINARY2)\n/' \
+ -e '72i $(BINARY):' -e '73i\\n$(BINARY2):' test/libdrampowertest/Makefile
+sed -i '34a # Modified for slackbuilds.org at 29 Oct 2022 by William PC - Seattle (USA)' test/libdrampowertest/Makefile
+
+cp -av $CWD/DRAMPowerTraces-$TRACES_COMMIT.zip traces.zip
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make
+
+# installing
+install -d $PKG/usr/bin
+install -m 755 drampower $PKG/usr/bin
+install -d $PKG/usr/include/libdrampower
+install -m 644 src/libdrampower/*.h $PKG/usr/include/libdrampower
+install -m 644 src/*.h $PKG/usr/include/libdrampower
+install -d $PKG/usr/include/libdrampower/xmlparser
+install -m 644 src/xmlparser/*.h $PKG/usr/include/libdrampower/xmlparser
+install -d $PKG/usr/lib${LIBDIRSUFFIX}
+install -m 644 src/{libdrampower.a,libdrampowerxml.a} $PKG/usr/lib${LIBDIRSUFFIX}
+
+mkdir -p $PKG/usr/share/$PRGNAM-$VERSION
+cp -av memspecs traces $PKG/usr/share/$PRGNAM-$VERSION
+
+mkdir -p $PKG/usr/share/$PRGNAM-$VERSION/examples
+cp -av test/libdrampowertest $PKG/usr/share/$PRGNAM-$VERSION/examples
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ ChangeLog README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/DRAMPower/DRAMPower.info b/academic/DRAMPower/DRAMPower.info
new file mode 100644
index 0000000000..16fb158264
--- /dev/null
+++ b/academic/DRAMPower/DRAMPower.info
@@ -0,0 +1,12 @@
+PRGNAM="DRAMPower"
+VERSION="4.1"
+HOMEPAGE="https://www.uni-kl.de/en/3d-dram/tools/drampower"
+DOWNLOAD="https://github.com/tukl-msd/DRAMPower/archive/v4.1/DRAMPower-4.1.tar.gz \
+ https://github.com/Sv3n/DRAMPowerTraces/archive/e640d3f7ff3766cdf4a799943f81e6ffe0946fb4/DRAMPowerTraces-e640d3f7ff3766cdf4a799943f81e6ffe0946fb4.zip"
+MD5SUM="9f93091c13c01d32f7cc22e609a8f1c3 \
+ 8c3bbf7d031f531f5630e0058e22d8e3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="xerces-c"
+MAINTAINER="William PC"
+EMAIL="w_calandrini[at]hotmail[dot]com"
diff --git a/academic/DRAMPower/README b/academic/DRAMPower/README
new file mode 100644
index 0000000000..be3cb3f5fa
--- /dev/null
+++ b/academic/DRAMPower/README
@@ -0,0 +1,29 @@
+ DRAMPower is an open source tool for fast and accurate DRAM power
+and energy estimation for DRAM memories. The latest version of
+the tool is v4.0 and features many important improvements, such as
+significantly improved analysis speed (at least 10x), enabling
+analysis of much larger traces, as well as support for DDR2/DDR3,
+LPDDR/LPDDR2, DDR4 and Wide I/O memories. The tool is based on the
+DRAM power model developed jointly by the Computer Engineering
+Research Group at TU Delft and the Electronic Systems Group at
+TU Eindhoven and has been verified by the Microelectronic System
+Design Research Group at TU Kaiserslautern with equivalent
+circuit-level simulations, which established that the error of
+the tool to be < 2% for all memory operations of any granularity
+for all memories supported by DRAMPower. DRAMPower is also part
+of the computer architecture simulator gem5.
+
+
+ Invocation example:
+ # drampower -m /usr/share/DRAMPower-4.1/memspecs/MICRON_1Gb_DDR3-\
+1066_8bit_G.xml -c /usr/share/DRAMPower-4.1/traces/commands.trace
+
+ Examples of using the library are located at:
+ # /usr/share/DRAMPower-4.1/examples/libdrampowertest
+
+ You can copy them to a working dir and then run "make test" for
+testing, as following:
+ # cp -av /usr/share/DRAMPower-4.1/examples/libdrampowertest .
+ # cd libdrampowertest
+ # make test
+
diff --git a/academic/DRAMPower/slack-desc b/academic/DRAMPower/slack-desc
new file mode 100644
index 0000000000..c7c49f03c4
--- /dev/null
+++ b/academic/DRAMPower/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+DRAMPower: DRAMPower (DRAM Power and Energy Estimation for DRAM)
+DRAMPower:
+DRAMPower:
+DRAMPower: DRAMPower is an open source tool for fast and accurate DRAM power
+DRAMPower: and energy estimation for DRAM memories. The latest version of
+DRAMPower: the tool is v4.0 and features many important improvements, such as
+DRAMPower: significantly improved analysis speed (at least 10x), enabling
+DRAMPower: analysis of much larger traces, as well as support for DDR2/DDR3,
+DRAMPower: LPDDR/LPDDR2, DDR4 and Wide I/O memories.
+DRAMPower:
+DRAMPower: