summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/python-wordpress-xmlrpc/slack-desc19
-rw-r--r--python/python2-wordpress-xmlrpc/README (renamed from python/python-wordpress-xmlrpc/README)0
-rw-r--r--python/python2-wordpress-xmlrpc/python2-wordpress-xmlrpc.SlackBuild (renamed from python/python-wordpress-xmlrpc/python-wordpress-xmlrpc.SlackBuild)17
-rw-r--r--python/python2-wordpress-xmlrpc/python2-wordpress-xmlrpc.info (renamed from python/python-wordpress-xmlrpc/python-wordpress-xmlrpc.info)2
-rw-r--r--python/python2-wordpress-xmlrpc/slack-desc19
5 files changed, 29 insertions, 28 deletions
diff --git a/python/python-wordpress-xmlrpc/slack-desc b/python/python-wordpress-xmlrpc/slack-desc
deleted file mode 100644
index 17d0f4d208..0000000000
--- a/python/python-wordpress-xmlrpc/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-wordpress-xmlrpc: python-wordpress-xmlrpc (write blog articles in wordpress with python)
-python-wordpress-xmlrpc:
-python-wordpress-xmlrpc: Python library to interface with a WordPress blog's XML-RPC API.
-python-wordpress-xmlrpc:
-python-wordpress-xmlrpc: An implementation of the standard WordPress API methods is provided,
-python-wordpress-xmlrpc: but the library is designed for easy integration with custom XML-RPC
-python-wordpress-xmlrpc: API methods provided by plugins.
-python-wordpress-xmlrpc:
-python-wordpress-xmlrpc: This library was developed against and tested on WordPress 3.5. This
-python-wordpress-xmlrpc: library is compatible with Python 2.6+ and 3.2+.
-python-wordpress-xmlrpc:
diff --git a/python/python-wordpress-xmlrpc/README b/python/python2-wordpress-xmlrpc/README
index 035a437e6a..035a437e6a 100644
--- a/python/python-wordpress-xmlrpc/README
+++ b/python/python2-wordpress-xmlrpc/README
diff --git a/python/python-wordpress-xmlrpc/python-wordpress-xmlrpc.SlackBuild b/python/python2-wordpress-xmlrpc/python2-wordpress-xmlrpc.SlackBuild
index 9e00bce51e..62f4d4e7d5 100644
--- a/python/python-wordpress-xmlrpc/python-wordpress-xmlrpc.SlackBuild
+++ b/python/python2-wordpress-xmlrpc/python2-wordpress-xmlrpc.SlackBuild
@@ -22,14 +22,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PRGNAM=python-wordpress-xmlrpc
+PRGNAM=python2-wordpress-xmlrpc
+SRCNAM=python-wordpress-xmlrpc
VERSION=${VERSION:-2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -59,9 +60,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -69,7 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
diff --git a/python/python-wordpress-xmlrpc/python-wordpress-xmlrpc.info b/python/python2-wordpress-xmlrpc/python2-wordpress-xmlrpc.info
index 0bd37c97c3..5bc5b7728f 100644
--- a/python/python-wordpress-xmlrpc/python-wordpress-xmlrpc.info
+++ b/python/python2-wordpress-xmlrpc/python2-wordpress-xmlrpc.info
@@ -1,4 +1,4 @@
-PRGNAM="python-wordpress-xmlrpc"
+PRGNAM="python2-wordpress-xmlrpc"
VERSION="2.2"
HOMEPAGE="https://pypi.python.org/pypi/python-wordpress-xmlrpc"
DOWNLOAD="https://pypi.python.org/packages/source/p/python-wordpress-xmlrpc/python-wordpress-xmlrpc-2.2.tar.gz"
diff --git a/python/python2-wordpress-xmlrpc/slack-desc b/python/python2-wordpress-xmlrpc/slack-desc
new file mode 100644
index 0000000000..e9543162d0
--- /dev/null
+++ b/python/python2-wordpress-xmlrpc/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-wordpress-xmlrpc: python2-wordpress-xmlrpc (write blog articles in wordpress w/ python)
+python2-wordpress-xmlrpc:
+python2-wordpress-xmlrpc: Python library to interface with a WordPress blog's XML-RPC API.
+python2-wordpress-xmlrpc:
+python2-wordpress-xmlrpc: An implementation of the standard WordPress API methods is provided,
+python2-wordpress-xmlrpc: but the library is designed for easy integration with custom XML-RPC
+python2-wordpress-xmlrpc: API methods provided by plugins.
+python2-wordpress-xmlrpc:
+python2-wordpress-xmlrpc: This library was developed against and tested on WordPress 3.5. This
+python2-wordpress-xmlrpc: library is compatible with Python 2.6+ and 3.2+.
+python2-wordpress-xmlrpc: