summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--gis/python3-shapely/python3-shapely.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/gis/python3-shapely/python3-shapely.SlackBuild b/gis/python3-shapely/python3-shapely.SlackBuild
index 20da7f0a13..12a2c42b8b 100644
--- a/gis/python3-shapely/python3-shapely.SlackBuild
+++ b/gis/python3-shapely/python3-shapely.SlackBuild
@@ -74,7 +74,8 @@ sed -i 's/oldest-supported-numpy/numpy>=1.19.3/' pyproject.toml
# Requires newer version of setuptools than available in -stable. Has not
# effect on -current
-export PYTHONPATH=/opt/python3.9/site-packages
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl