summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--libraries/pexpect/pexpect.SlackBuild9
1 files changed, 1 insertions, 8 deletions
diff --git a/libraries/pexpect/pexpect.SlackBuild b/libraries/pexpect/pexpect.SlackBuild
index d0fe55a4b5..4ddbd7ee9e 100644
--- a/libraries/pexpect/pexpect.SlackBuild
+++ b/libraries/pexpect/pexpect.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for Pexpect
# Copyright (c) 2007 Javier Rojas <jerojasro@gmail.com>
-# Copyright 2014-2018 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2014-2022 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -81,10 +78,6 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION