summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--system/trmaid/README2
-rw-r--r--system/trmaid/doinst.sh3
-rw-r--r--system/trmaid/slack-desc19
-rw-r--r--system/trmaid/trmaid.SlackBuild96
-rw-r--r--system/trmaid/trmaid.info10
5 files changed, 0 insertions, 130 deletions
diff --git a/system/trmaid/README b/system/trmaid/README
deleted file mode 100644
index 9374ed8ebe..0000000000
--- a/system/trmaid/README
+++ /dev/null
@@ -1,2 +0,0 @@
-Takes care of transmission settings, keeps torrents under check
-nd adds em from feed or redis queue (well list actually).
diff --git a/system/trmaid/doinst.sh b/system/trmaid/doinst.sh
deleted file mode 100644
index 5fb28930db..0000000000
--- a/system/trmaid/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/system/trmaid/slack-desc b/system/trmaid/slack-desc
deleted file mode 100644
index e027dd5d19..0000000000
--- a/system/trmaid/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-trmaid: trmaid (maintain transmission)
-trmaid:
-trmaid: Takes care of transmission settings, keeps torrents
-trmaid: under check and adds em from feed or redis queue
-trmaid: (well list actually).
-trmaid:
-trmaid: Homepage: https://github.com/tanelpuhu/trmaid
-trmaid:
-trmaid:
-trmaid:
-trmaid:
diff --git a/system/trmaid/trmaid.SlackBuild b/system/trmaid/trmaid.SlackBuild
deleted file mode 100644
index 8b0e6ddf50..0000000000
--- a/system/trmaid/trmaid.SlackBuild
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for trmaid
-
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=trmaid
-VERSION=${VERSION:-0.6.8}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/trmaid/trmaid.info b/system/trmaid/trmaid.info
deleted file mode 100644
index 84a7504e41..0000000000
--- a/system/trmaid/trmaid.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="trmaid"
-VERSION="0.6.8"
-HOMEPAGE="https://pypi.python.org/pypi/trmaid/"
-DOWNLOAD="https://pypi.python.org/packages/2b/a8/d171162c41f760a012284e4ebae6a3b345ce647479344600d470281a8eab/trmaid-0.6.8.tar.gz"
-MD5SUM="65ea65b6ce3b146ffa5109a420b5f605"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python2-PyYAML feedparser redis-py"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"