summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/fifengine/8072f18a9bf4e75c3e1b197b6ccda11e82954460.patch25
-rw-r--r--games/fifengine/d14f232f4cd9a00b05d6872957070e8c020f515d.patch22
-rw-r--r--games/fifengine/fifengine.SlackBuild6
-rw-r--r--games/fifengine/fifengine.info6
4 files changed, 54 insertions, 5 deletions
diff --git a/games/fifengine/8072f18a9bf4e75c3e1b197b6ccda11e82954460.patch b/games/fifengine/8072f18a9bf4e75c3e1b197b6ccda11e82954460.patch
new file mode 100644
index 0000000000..375fa6c73c
--- /dev/null
+++ b/games/fifengine/8072f18a9bf4e75c3e1b197b6ccda11e82954460.patch
@@ -0,0 +1,25 @@
+From 8072f18a9bf4e75c3e1b197b6ccda11e82954460 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Tue, 31 Aug 2021 17:45:12 +0200
+Subject: [PATCH] Fix build against boost-1.77.0
+
+boost-1.77.0 no longer includes <algorithm>
+
+Closes: #1080
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ engine/core/vfs/zip/zipnode.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/engine/core/vfs/zip/zipnode.cpp b/engine/core/vfs/zip/zipnode.cpp
+index a1b14abbd..e1613e7f4 100644
+--- a/engine/core/vfs/zip/zipnode.cpp
++++ b/engine/core/vfs/zip/zipnode.cpp
+@@ -28,6 +28,7 @@
+ #include "vfs/fife_boost_filesystem.h"
+
+ #include "zipnode.h"
++#include <algorithm>
+
+ namespace {
+ /** helper function to find a value in a ZipNodeContainer
diff --git a/games/fifengine/d14f232f4cd9a00b05d6872957070e8c020f515d.patch b/games/fifengine/d14f232f4cd9a00b05d6872957070e8c020f515d.patch
new file mode 100644
index 0000000000..6450c91f32
--- /dev/null
+++ b/games/fifengine/d14f232f4cd9a00b05d6872957070e8c020f515d.patch
@@ -0,0 +1,22 @@
+From d14f232f4cd9a00b05d6872957070e8c020f515d Mon Sep 17 00:00:00 2001
+From: Thomas Kowaliczek-Schmer <linuxdonald@posteo.de>
+Date: Wed, 22 May 2019 16:04:43 +0200
+Subject: [PATCH] removed flags that are not supported with swig 4.0
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 126322ce0..25c695630 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -893,7 +893,7 @@ if(build-python)
+ find_package(PythonLibs ${PYTHON_VERSION_STRING} EXACT)
+ include_directories(${PYTHON_INCLUDE_PATH})
+
+- set(CMAKE_SWIG_FLAGS -modern -fastdispatch -dirvtable -nosafecstrings -noproxydel -fastproxy -fastinit -fastunpack -fastquery -modernargs -nobuildnone -keyword -w511 -w473 -w404 -w314)
++ set(CMAKE_SWIG_FLAGS -modern -fastdispatch -dirvtable -noproxydel -fastproxy -fastinit -fastunpack -fastquery -modernargs -keyword -w511 -w473 -w404 -w314)
+
+ set_source_files_properties("${PROJECT_BINARY_DIR}/fife.i" PROPERTIES CPLUSPLUS ON)
+ set(FIFE_SOURCES ${FIFE_CORE_SRC})
diff --git a/games/fifengine/fifengine.SlackBuild b/games/fifengine/fifengine.SlackBuild
index df22d4889e..bc226b6f94 100644
--- a/games/fifengine/fifengine.SlackBuild
+++ b/games/fifengine/fifengine.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=fifengine
-VERSION=${VERSION:-0.4.1}
+VERSION=${VERSION:-0.4.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -70,7 +70,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -79,6 +79,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p1 < $CWD/d14f232f4cd9a00b05d6872957070e8c020f515d.patch
+patch -p1 < $CWD/8072f18a9bf4e75c3e1b197b6ccda11e82954460.patch
mkdir -p build
cd build
cmake \
diff --git a/games/fifengine/fifengine.info b/games/fifengine/fifengine.info
index deb3aeb938..18cf364446 100644
--- a/games/fifengine/fifengine.info
+++ b/games/fifengine/fifengine.info
@@ -1,8 +1,8 @@
PRGNAM="fifengine"
-VERSION="0.4.1"
+VERSION="0.4.2"
HOMEPAGE="http://www.fifengine.net/"
-DOWNLOAD="https://github.com/fifengine/fifengine/archive/0.4.1.tar.gz"
-MD5SUM="6ce5533102c4993b44c3ba8347f4ca93"
+DOWNLOAD="https://github.com/fifengine/fifengine/archive/0.4.2/fifengine-0.4.2.tar.gz"
+MD5SUM="3a1a0d7c6332ad80d810a5962b2208c3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="tinyxml fifechan"