summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/yabause/qt-5.11.patch47
-rw-r--r--games/yabause/yabause.SlackBuild7
2 files changed, 50 insertions, 4 deletions
diff --git a/games/yabause/qt-5.11.patch b/games/yabause/qt-5.11.patch
new file mode 100644
index 0000000000..bae3d80bd9
--- /dev/null
+++ b/games/yabause/qt-5.11.patch
@@ -0,0 +1,47 @@
+diff -Naur yabause-0.9.15.orig/src/qt/ui/UICheatRaw.cpp yabause-0.9.15/src/qt/ui/UICheatRaw.cpp
+--- yabause-0.9.15.orig/src/qt/ui/UICheatRaw.cpp 2016-08-19 17:31:13.000000000 +0200
++++ yabause-0.9.15/src/qt/ui/UICheatRaw.cpp 2022-03-04 20:54:59.817095000 +0100
+@@ -20,8 +20,6 @@
+ #include "UIHexInput.h"
+ #include "../QtYabause.h"
+
+-#include <QButtonGroup>
+-
+ UICheatRaw::UICheatRaw( QWidget* p )
+ : QDialog( p )
+ {
+diff -Naur yabause-0.9.15.orig/src/qt/ui/UICheatRaw.h yabause-0.9.15/src/qt/ui/UICheatRaw.h
+--- yabause-0.9.15.orig/src/qt/ui/UICheatRaw.h 2016-08-19 17:31:13.000000000 +0200
++++ yabause-0.9.15/src/qt/ui/UICheatRaw.h 2022-03-04 20:55:40.401095000 +0100
+@@ -20,8 +20,7 @@
+ #define UICHEATRAW_H
+
+ #include "ui_UICheatRaw.h"
+-
+-class QButtonGroup;
++#include <QButtonGroup>
+
+ class UICheatRaw : public QDialog, public Ui::UICheatRaw
+ {
+diff -Naur yabause-0.9.15.orig/src/qt/ui/UICheats.cpp yabause-0.9.15/src/qt/ui/UICheats.cpp
+--- yabause-0.9.15.orig/src/qt/ui/UICheats.cpp 2016-08-19 17:31:13.000000000 +0200
++++ yabause-0.9.15/src/qt/ui/UICheats.cpp 2022-03-04 20:56:02.818095000 +0100
+@@ -20,6 +20,7 @@
+ #include "UICheatAR.h"
+ #include "UICheatRaw.h"
+ #include "../CommonDialogs.h"
++#include <QButtonGroup>
+
+ UICheats::UICheats( QWidget* p )
+ : QDialog( p )
+diff -Naur yabause-0.9.15.orig/src/qt/ui/UIHexInput.h yabause-0.9.15/src/qt/ui/UIHexInput.h
+--- yabause-0.9.15.orig/src/qt/ui/UIHexInput.h 2016-08-19 17:31:13.000000000 +0200
++++ yabause-0.9.15/src/qt/ui/UIHexInput.h 2022-03-04 20:56:27.297095000 +0100
+@@ -21,6 +21,7 @@
+
+ #include "ui_UIHexInput.h"
+ #include "../QtYabause.h"
++#include <QValidator>
+
+ class HexValidator : public QValidator
+ {
diff --git a/games/yabause/yabause.SlackBuild b/games/yabause/yabause.SlackBuild
index c7b82f73eb..8e5e155aee 100644
--- a/games/yabause/yabause.SlackBuild
+++ b/games/yabause/yabause.SlackBuild
@@ -79,10 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-# Variable to determine gtk/qt interface. Default is qt.
-# 20220221 bkw: hardcoded to gtk, because qt won't build on Slackware 15.0.
-# Possibly it would with qt4, but not qt5.
-USE_GUI=gtk
+USE_GUI=qt
# Fix location of man file.
sed -i 's|share/man|man|' src/CMakeLists.txt
@@ -97,6 +94,8 @@ done
# Patch against ffmpeg 3
patch -p1 < $CWD/ffmpeg3.patch
+patch -p1 < $CWD/qt-5.11.patch
+
mkdir build
cd build
cmake -G "Unix Makefiles" \