summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/python-poppler-qt4/README2
-rw-r--r--python/python-poppler-qt4/python-poppler-qt4.SlackBuild79
-rw-r--r--python/python-poppler-qt4/python-poppler-qt4.info10
-rw-r--r--python/python-poppler-qt4/slack-desc19
4 files changed, 0 insertions, 110 deletions
diff --git a/python/python-poppler-qt4/README b/python/python-poppler-qt4/README
deleted file mode 100644
index dc8db20d89..0000000000
--- a/python/python-poppler-qt4/README
+++ /dev/null
@@ -1,2 +0,0 @@
-A Python binding to poppler-qt4 that aims for completeness and for being
-actively maintained.
diff --git a/python/python-poppler-qt4/python-poppler-qt4.SlackBuild b/python/python-poppler-qt4/python-poppler-qt4.SlackBuild
deleted file mode 100644
index f082139e8a..0000000000
--- a/python/python-poppler-qt4/python-poppler-qt4.SlackBuild
+++ /dev/null
@@ -1,79 +0,0 @@
-#!/bin/bash
-# Slackware build script for <python-poppler-qt4>
-#
-# Michales - clavisound - Michaloudes korgie@gmail.com <2012>
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python-poppler-qt4
-VERSION=${VERSION:-0.24.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py build
-python setup.py install --root $PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- ChangeLog README.rst TODO INSTALL LICENSE \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python-poppler-qt4/python-poppler-qt4.info b/python/python-poppler-qt4/python-poppler-qt4.info
deleted file mode 100644
index cf8cf7415a..0000000000
--- a/python/python-poppler-qt4/python-poppler-qt4.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-poppler-qt4"
-VERSION="0.24.0"
-HOMEPAGE="https://github.com/wbsoft/python-poppler-qt4"
-DOWNLOAD="https://github.com/wbsoft/python-poppler-qt4/archive/v0.24.0/python-poppler-qt4-0.24.0.tar.gz"
-MD5SUM="c6d4a1038329350ca01704e7c2613f4f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Michales Michaloudes"
-EMAIL="korgie@gmail.com"
diff --git a/python/python-poppler-qt4/slack-desc b/python/python-poppler-qt4/slack-desc
deleted file mode 100644
index a7c755c71d..0000000000
--- a/python/python-poppler-qt4/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-poppler-qt4: python-poppler-qt4 (Python bindings to poppler-qt4)
-python-poppler-qt4:
-python-poppler-qt4: A Python binding to poppler-qt4 that aims for completeness
-python-poppler-qt4: and for being actively maintained.
-python-poppler-qt4:
-python-poppler-qt4:
-python-poppler-qt4:
-python-poppler-qt4:
-python-poppler-qt4:
-python-poppler-qt4:
-python-poppler-qt4: