summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/feedparser/README7
-rw-r--r--python/feedparser/feedparser.SlackBuild21
-rw-r--r--python/feedparser/feedparser.info6
3 files changed, 14 insertions, 20 deletions
diff --git a/python/feedparser/README b/python/feedparser/README
index 0f7ef1c4a5..97ea1ec77a 100644
--- a/python/feedparser/README
+++ b/python/feedparser/README
@@ -1 +1,8 @@
feedparser is a Python utility library to parse RSS and Atom feeds.
+
+Since update to version 6.0.8, along with sgmllib being dropped from python3
+it is now necessary to manually add necessary sgml support by running (as root):
+ python3 -m pip install sgmllib3k
+
+This will enable 'import feedparser' to work as expected with python3
+until a SlackBuild for sgmllib3k is able to be included at SBo.
diff --git a/python/feedparser/feedparser.SlackBuild b/python/feedparser/feedparser.SlackBuild
index d777317ae2..1743c87784 100644
--- a/python/feedparser/feedparser.SlackBuild
+++ b/python/feedparser/feedparser.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for feedparser
# Modified by Luis Henrique <lmello.009@gmail.com>
-# Maintained 2014-2019 by Christoph Willing <chris.willing@linux.com>
+# Maintained 2014-2021 by Christoph Willing <chris.willing@linux.com>
# Copyright 2008-2009 Chess Griffin <chess@chessgriffin.com>
# All rights reserved.
@@ -27,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=feedparser
-VERSION=${VERSION:-5.2.1}
+VERSION=${VERSION:-6.0.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -83,21 +83,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py build
-python setup.py install --root $PKG
-if $(python3 -c 'import sys' 2>/dev/null); then
- # Python3 doesn't have sgmllib so we provide it here for building
- # and later installation as part of the feedparser package.
- cp feedparser/sgmllib3.py feedparser/sgmllib.py
- PYTHONPATH=$(pwd)/feedparser:$PYTHONPATH
-
- patch -p0 < $CWD/001_py37.diff
- python3 setup.py build
- python3 setup.py install --root $PKG
-
- PYSITEDIR=$(python3 -c "import site; print(site.getsitepackages()[0])")
- install -m 0644 feedparser/sgmllib.py $PKG/$PYSITEDIR
-fi
+python3 setup.py build
+python3 setup.py install --root $PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/feedparser/feedparser.info b/python/feedparser/feedparser.info
index fe8c8895d9..b50ce7f5c7 100644
--- a/python/feedparser/feedparser.info
+++ b/python/feedparser/feedparser.info
@@ -1,8 +1,8 @@
PRGNAM="feedparser"
-VERSION="5.2.1"
+VERSION="6.0.8"
HOMEPAGE="https://github.com/kurtmckee/feedparser"
-DOWNLOAD="https://github.com/kurtmckee/feedparser/archive/5.2.1/feedparser-5.2.1.tar.gz"
-MD5SUM="885d800496ffd538920960b9dbc45faf"
+DOWNLOAD="https://github.com/kurtmckee/feedparser/archive/6.0.8/feedparser-6.0.8.tar.gz"
+MD5SUM="bd9a217102307b1c4518bff2cab56bb7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""