summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--gis/python3-basemap/python3-basemap.SlackBuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/gis/python3-basemap/python3-basemap.SlackBuild b/gis/python3-basemap/python3-basemap.SlackBuild
index be680b696f..24558ad5b0 100644
--- a/gis/python3-basemap/python3-basemap.SlackBuild
+++ b/gis/python3-basemap/python3-basemap.SlackBuild
@@ -80,6 +80,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# regenerate cythonized sources
+# thanks arch linux maintainers
+cythonize --force src/_geoslib.pyx
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \