summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/alabaster/README13
-rw-r--r--python/alabaster/alabaster.SlackBuild97
-rw-r--r--python/alabaster/alabaster.info10
-rw-r--r--python/alabaster/slack-desc19
4 files changed, 0 insertions, 139 deletions
diff --git a/python/alabaster/README b/python/alabaster/README
deleted file mode 100644
index 596320ef6e..0000000000
--- a/python/alabaster/README
+++ /dev/null
@@ -1,13 +0,0 @@
-A configurable sidebar-enabled Sphinx theme
-
-Alabaster is a visually (c)lean, responsive, configurable theme
-for the Sphinx documentation system. It is Python 2+3 compatible.
-
-It began as a third-party theme, and is still maintained separately,
-but as of Sphinx 1.3, Alabaster is an install-time dependency
-of Sphinx and is selected as the default theme.
-
-Live examples of this theme can be seen on this project's own
-website, paramiko.org, fabfile.org and pyinvoke.org.
-
-For more documentation, please see http://alabaster.readthedocs.io.
diff --git a/python/alabaster/alabaster.SlackBuild b/python/alabaster/alabaster.SlackBuild
deleted file mode 100644
index ffc51ad38c..0000000000
--- a/python/alabaster/alabaster.SlackBuild
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for alabaster
-
-# Copyright 2017 Nikos Giotis <nikos.giotis@gmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Update 2023-11-25: Removed python2 support
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=alabaster
-VERSION=${VERSION:-0.7.13}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/alabaster/alabaster.info b/python/alabaster/alabaster.info
deleted file mode 100644
index 169e58e1b5..0000000000
--- a/python/alabaster/alabaster.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="alabaster"
-VERSION="0.7.13"
-HOMEPAGE="https://alabaster.readthedocs.io/"
-DOWNLOAD="https://files.pythonhosted.org/packages/94/71/a8ee96d1fd95ca04a0d2e2d9c4081dac4c2d2b12f7ddb899c8cb9bfd1532/alabaster-0.7.13.tar.gz"
-MD5SUM="2e05a5f4fe5a8b95e5e576cbf4a5d503"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Nikos Giotis"
-EMAIL="nikos.giotis@gmail.com"
diff --git a/python/alabaster/slack-desc b/python/alabaster/slack-desc
deleted file mode 100644
index ac64dcfad2..0000000000
--- a/python/alabaster/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-alabaster: alabaster (A configurable sidebar-enabled Sphinx theme)
-alabaster:
-alabaster: Alabaster is a visually (c)lean, responsive, configurable theme for
-alabaster: the Sphinx documentation system. It is Python 2+3 compatible.
-alabaster:
-alabaster: https://alabaster.readthedocs.io/
-alabaster:
-alabaster:
-alabaster:
-alabaster:
-alabaster: