summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/dnspython/README3
-rw-r--r--python/dnspython/dnspython.SlackBuild8
2 files changed, 8 insertions, 3 deletions
diff --git a/python/dnspython/README b/python/dnspython/README
index 4ff3ee0745..8ec893d537 100644
--- a/python/dnspython/README
+++ b/python/dnspython/README
@@ -7,4 +7,5 @@ level classes perform queries for data of a given name, type, and
class, and return an answer set. The low level classes allow direct
manipulation of DNS zones, messages, names, and records.
-pycrypto and ecdsa are optional dependencies for DNSSEC functionality.
+python3, pycrypto and ecdsa are optional dependencies for DNSSEC
+functionality.
diff --git a/python/dnspython/dnspython.SlackBuild b/python/dnspython/dnspython.SlackBuild
index 20cf6e95ee..d5df6ee9e4 100644
--- a/python/dnspython/dnspython.SlackBuild
+++ b/python/dnspython/dnspython.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for dnspython
-# Copyright 2009-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=dnspython
VERSION=${VERSION:-1.15.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -57,6 +57,10 @@ find -L . \
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true