summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/lutris/lutris.SlackBuild34
-rw-r--r--games/lutris/lutris.info12
2 files changed, 31 insertions, 15 deletions
diff --git a/games/lutris/lutris.SlackBuild b/games/lutris/lutris.SlackBuild
index 73ddf9f8b9..39896a4453 100644
--- a/games/lutris/lutris.SlackBuild
+++ b/games/lutris/lutris.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for lutris
# Ryan P.C. McQuen | Everett, WA | ryanpcmcquen@member.fsf.org
-# Copyright 2018 Brenton Earl <brent@exitstatusone.com>
+# Copyright 2018, 2022 Brenton Earl <brent@exitstatusone.com>
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=lutris
-VERSION=${VERSION:-0.4.23}
+VERSION=${VERSION:-0.5.9.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -35,13 +35,11 @@ if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
+ aarch64) ARCH=$( uname -m ) ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,7 +49,24 @@ TMP=${TMP:-/tmp/SBo}
PKG=${PKG:-$TMP/package-$PRGNAM}
OUTPUT=${OUTPUT:-/tmp}
-DOCS="AUTHORS CHANGELOG LICENSE INSTALL.rst README.rst"
+DOCS="AUTHORS LICENSE INSTALL.rst README.rst"
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
set -e
@@ -59,8 +74,8 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM
-tar xvf $CWD/$PRGNAM\_$VERSION.tar.xz
-cd $PRGNAM
+tar xvf $CWD/$PRGNAM\-$VERSION.tar.?z
+cd $PRGNAM\-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -68,7 +83,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root $PKG
+python3 setup.py build
+python3 setup.py install --root="$PKG" --optimize=1 --skip-build
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/games/lutris/lutris.info b/games/lutris/lutris.info
index 88b945f081..fad9380e1e 100644
--- a/games/lutris/lutris.info
+++ b/games/lutris/lutris.info
@@ -1,10 +1,10 @@
PRGNAM="lutris"
-VERSION="0.4.23"
+VERSION="0.5.9.1"
HOMEPAGE="https://lutris.net/"
-DOWNLOAD="http://lutris.net/releases/lutris_0.4.23.tar.xz"
-MD5SUM="2300a2f6e617cf222aa47acd0b72436f"
+DOWNLOAD="https://github.com/lutris/lutris/archive/refs/tags/v0.5.9.1/lutris-0.5.9.1.tar.gz"
+MD5SUM="948e18e95750ca0f0af120ea86efe1f6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Brenton Earl"
-EMAIL="brent@exitstatusone.com"
+REQUIRES="python-magic gnome-desktop webkit2gtk lxml"
+MAINTAINER="Ozan Türkyılmaz"
+EMAIL="ozan.turkyilmaz@gmail.com"