summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/python-distutils-extra/README4
-rw-r--r--python/python-distutils-extra/python-distutils-extra.SlackBuild6
2 files changed, 1 insertions, 9 deletions
diff --git a/python/python-distutils-extra/README b/python/python-distutils-extra/README
index 90754780d3..5e652e923f 100644
--- a/python/python-distutils-extra/README
+++ b/python/python-distutils-extra/README
@@ -2,7 +2,3 @@ Python-distutils-extra allows to easily integrate themable icons,
scrollkeeper based documentation, and gettext based translations in
your python install and build tools. It can be used with python's
distutils or the enhanced setuptools.
-
-To install python3 bindings run the slackbuild with PYTHON3=yes.
-
- # PYTHON3=yes ./python-distutils-extra.SlackBuild
diff --git a/python/python-distutils-extra/python-distutils-extra.SlackBuild b/python/python-distutils-extra/python-distutils-extra.SlackBuild
index 9e25ef75a7..5ff5ef359f 100644
--- a/python/python-distutils-extra/python-distutils-extra.SlackBuild
+++ b/python/python-distutils-extra/python-distutils-extra.SlackBuild
@@ -56,11 +56,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-
-# Install python3 bindings for distutils-extra. Default is no.
-if [ "${PYTHON3:-no}" == "yes" ]; then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true