summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/qm-vamp-plugins/qm-vamp-plugins.SlackBuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/audio/qm-vamp-plugins/qm-vamp-plugins.SlackBuild b/audio/qm-vamp-plugins/qm-vamp-plugins.SlackBuild
index 14b26d8bc4..dae6bab1f8 100644
--- a/audio/qm-vamp-plugins/qm-vamp-plugins.SlackBuild
+++ b/audio/qm-vamp-plugins/qm-vamp-plugins.SlackBuild
@@ -6,9 +6,12 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20150403 bkw:
+# Bump BUILD to 3, make it build against vamp-plugin-sdk 2.5 (whoops)
+
PRGNAM=qm-vamp-plugins
VERSION=${VERSION:-1.7}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -134,6 +137,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# 20150403 bkw: crap. getting rid of vamp-plugin-sdk static libs
+# breaks this. Fix by getting rid of -Wl,-Bstatic and -Wl,-Bdynamic
+# options (so it doesn't insisnt on a static libvamp-sdk).
+sed -i 's/-Wl,-B[^ ]* //g' build/linux/Makefile.linux64
fix_sse_flags build/linux/Makefile.linux64
make -f build/linux/Makefile.linux64