summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/ace/ace.SlackBuild3
-rw-r--r--games/ace/ace14_fixes.patch57
2 files changed, 60 insertions, 0 deletions
diff --git a/games/ace/ace.SlackBuild b/games/ace/ace.SlackBuild
index 34edbe8c7b..50c2417573 100644
--- a/games/ace/ace.SlackBuild
+++ b/games/ace/ace.SlackBuild
@@ -51,6 +51,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Patch for libpng and other fixes thanks to Arch Linux
+patch -p1 < $CWD/ace14_fixes.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/games/ace/ace14_fixes.patch b/games/ace/ace14_fixes.patch
new file mode 100644
index 0000000000..df1137dc9f
--- /dev/null
+++ b/games/ace/ace14_fixes.patch
@@ -0,0 +1,57 @@
+--- ace14/lib/xwin.c
++++ ace-1.4/lib/xwin.c
+@@ -89,10 +89,10 @@
+ /* Motif window hints */
+ typedef struct
+ {
+- unsigned flags;
+- unsigned functions;
+- unsigned decorations;
+- int inputMode;
++ unsigned long flags;
++ unsigned long functions;
++ unsigned long decorations;
++ long inputMode;
+ } PropMotifWmHints;
+
+ typedef PropMotifWmHints PropMwmHints;
+@@ -841,13 +841,13 @@
+ png_ptr = png_create_read_struct (PNG_LIBPNG_VER_STRING, 0, 0, 0);
+ info_ptr = png_create_info_struct (png_ptr);
+
+- if (setjmp (png_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf (png_ptr))) {
+ fprintf(stderr, "Invalid PNG image!\n");
+ return;
+ }
+
+ file_bytes = src->file_data;
+- png_set_read_fn (png_ptr, (voidp)&file_bytes, (png_rw_ptr)png_reader);
++ png_set_read_fn (png_ptr, (void *)&file_bytes, (png_rw_ptr)png_reader);
+
+ png_read_info (png_ptr, info_ptr);
+
+--- ace14/lib/make-imglib.c
++++ ace-1.4/lib/make-imglib.c
+@@ -86,7 +86,7 @@
+ png_ptr = png_create_read_struct (PNG_LIBPNG_VER_STRING, 0, 0, 0);
+ info_ptr = png_create_info_struct (png_ptr);
+
+- if (setjmp (png_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf (png_ptr))) {
+ fclose (f);
+ continue;
+ }
+
+--- ace14/lib/Makefile.am
++++ ace-1.4/lib/Makefile.am
+@@ -6,7 +6,7 @@
+ CLEANFILES = images.c images.d
+
+ INCLUDES = $(X_CFLAGS) @PDA@
+-AM_LDFLAGS = $(X_LIBS)
++AM_LDFLAGS = $(X_LIBS) -lpng -lz -lm
+
+ BUILD_CC = @BUILD_CC@
+ AR = @AR@
+