summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/pandocfilters/pandocfilters.SlackBuild7
-rw-r--r--python/pandocfilters/pandocfilters.info2
2 files changed, 5 insertions, 4 deletions
diff --git a/python/pandocfilters/pandocfilters.SlackBuild b/python/pandocfilters/pandocfilters.SlackBuild
index 042995ab07..50fbb8e69a 100644
--- a/python/pandocfilters/pandocfilters.SlackBuild
+++ b/python/pandocfilters/pandocfilters.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pandocfilters
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=pandocfilters
VERSION=${VERSION:-1.4.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,7 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/pandocfilters/pandocfilters.info b/python/pandocfilters/pandocfilters.info
index 6e1b19a907..da8245b0f3 100644
--- a/python/pandocfilters/pandocfilters.info
+++ b/python/pandocfilters/pandocfilters.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pandocfilters/pandocf
MD5SUM="dc391791ef54c7de1572d7b46b63361f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3"
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="slackbuilds@jaxartes.net"