summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/termcolor/termcolor.SlackBuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/python/termcolor/termcolor.SlackBuild b/python/termcolor/termcolor.SlackBuild
index 2934bada62..1619fc56eb 100644
--- a/python/termcolor/termcolor.SlackBuild
+++ b/python/termcolor/termcolor.SlackBuild
@@ -55,7 +55,7 @@ else
LIBDIRSUFFIX=""
fi
-set -e
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -70,10 +70,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
python setup.py install --root=$PKG
-# for Python 3
-# python3 setup.py install --root=$PKG
+
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true