summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--python/atomicwrites/README2
-rw-r--r--python/atomicwrites/atomicwrites.SlackBuild5
2 files changed, 7 insertions, 0 deletions
diff --git a/python/atomicwrites/README b/python/atomicwrites/README
index 2602e9896f..be2c03c913 100644
--- a/python/atomicwrites/README
+++ b/python/atomicwrites/README
@@ -13,3 +13,5 @@ and the name of the target file.
Also note that the permissions of the target file may change this way. In some
situations a chmod can be issued without any concurrency problems, but since
that is not always the case, this library doesn’t do it by itself.
+
+Optional dependency: python3
diff --git a/python/atomicwrites/atomicwrites.SlackBuild b/python/atomicwrites/atomicwrites.SlackBuild
index d582ebd8d3..9055219698 100644
--- a/python/atomicwrites/atomicwrites.SlackBuild
+++ b/python/atomicwrites/atomicwrites.SlackBuild
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true