summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--system/sandbox/sandbox.SlackBuild10
-rw-r--r--system/sandbox/slibtool.patch11
-rw-r--r--system/sandbox/slibtool.patch.gzbin604 -> 0 bytes
3 files changed, 17 insertions, 4 deletions
diff --git a/system/sandbox/sandbox.SlackBuild b/system/sandbox/sandbox.SlackBuild
index 3f763f52e7..c53e008657 100644
--- a/system/sandbox/sandbox.SlackBuild
+++ b/system/sandbox/sandbox.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=sandbox
VERSION=${VERSION:-2.13}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,11 +69,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix build with slibtool
-# https://bugs.gentoo.org/656184
-zcat $CWD/slibtool.patch.gz | patch -p1
+# Remove -nodefaultlibs to avoid compiler failures for 32-bit with slibtool.
+# GNU libtool swallows anything not on their list of "known" linker flags.
+# https://bugs.gentoo.org/657184
+patch -p1 < $CWD/slibtool.patch
autoreconf -fi
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/system/sandbox/slibtool.patch b/system/sandbox/slibtool.patch
new file mode 100644
index 0000000000..bf12277a20
--- /dev/null
+++ b/system/sandbox/slibtool.patch
@@ -0,0 +1,11 @@
+diff -ur sandbox-2.13.orig/libsandbox/Makefile.am sandbox-2.13/libsandbox/Makefile.am
+--- sandbox-2.13.orig/libsandbox/Makefile.am 2018-02-19 05:50:18.000000000 -0000
++++ sandbox-2.13/libsandbox/Makefile.am 2018-06-03 12:58:04.270611236 -0000
+@@ -20,7 +20,6 @@
+ # and destructor will not be executed ...
+ libsandbox_la_LDFLAGS = \
+ -no-undefined \
+- -nodefaultlibs \
+ -avoid-version \
+ $(LDFLAG_VER),libsandbox.map
+ libsandbox_la_SOURCES = \
diff --git a/system/sandbox/slibtool.patch.gz b/system/sandbox/slibtool.patch.gz
deleted file mode 100644
index 19b2ce79a9..0000000000
--- a/system/sandbox/slibtool.patch.gz
+++ /dev/null
Binary files differ