summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--network/offlineimap/offlineimap.SlackBuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/network/offlineimap/offlineimap.SlackBuild b/network/offlineimap/offlineimap.SlackBuild
index 5973d225cb..830bf4ab04 100644
--- a/network/offlineimap/offlineimap.SlackBuild
+++ b/network/offlineimap/offlineimap.SlackBuild
@@ -43,10 +43,10 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-set -e
+set -e
# In case the source was fetched with wget or some other downloader:
-[ -e v${VERSION} ] && mv v${VERSION} $PRGNAM.tar.gz
+[ -e v${VERSION}.tar.gz ] && mv v${VERSION}.tar.gz $PRGNAM-${VERSION}.tar.gz
rm -fr $TMP/$PRGNAM-$VERSION $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -56,10 +56,10 @@ cd $PRGNAM-$VERSION
chown -R root.root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
### build and install
python setup.py install --root=$PKG
@@ -77,9 +77,7 @@ install -m 0644 -D $PRGNAM.conf $PKG/etc/$PRGNAM.conf.new
install -m 0644 docs/$PRGNAM.1 $PKG/usr/man/man1
gzip -9 $PKG/usr/man/man1/$PRGNAM.1
-cp -a \
- COPYING README* $PRGNAM.conf* \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README* $PRGNAM.conf* $PKG/usr/doc/$PRGNAM-$VERSION
cp -a docs/INSTALL.html docs/MANUAL.html $PKG/usr/doc/$PRGNAM-$VERSION/html
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild