summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--libraries/matplotlib/README2
-rw-r--r--libraries/matplotlib/matplotlib.SlackBuild9
-rw-r--r--libraries/matplotlib/matplotlib.info6
3 files changed, 11 insertions, 6 deletions
diff --git a/libraries/matplotlib/README b/libraries/matplotlib/README
index 71f7c7f974..768e132806 100644
--- a/libraries/matplotlib/README
+++ b/libraries/matplotlib/README
@@ -4,4 +4,4 @@ development and web application servers targeting multiple user
interfaces and hardcopy output formats. There is a 'pylab' mode which
emulates matlab graphics
-This requires numpy.
+This requires numpy, pytz and python-dateutil.
diff --git a/libraries/matplotlib/matplotlib.SlackBuild b/libraries/matplotlib/matplotlib.SlackBuild
index 36fe64f31f..11ffa42bbd 100644
--- a/libraries/matplotlib/matplotlib.SlackBuild
+++ b/libraries/matplotlib/matplotlib.SlackBuild
@@ -8,7 +8,7 @@
PRGNAM=matplotlib
VERSION=${VERSION:-0.99.1.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
TARBALL_VERSION=0.99.1.1 # Tarball dir has wrong version number
@@ -45,13 +45,18 @@ find . \
patch -p1 < $CWD/libpng-1.4.patch
+# Use setup.cfg to tell setup.py not to install pytz and dateutil
+mv setup.cfg.template setup.cfg
+sed -i "s|#pytz|pytz|" setup.cfg
+sed -i "s|#dateutil|dateutil|" setup.cfg
+
python setup.py install --root $PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-install -m 0644 \
+cp -a \
CHANGELOG INSTALL INTERACTIVE KNOWN_BUGS README.txt TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/libraries/matplotlib/matplotlib.info b/libraries/matplotlib/matplotlib.info
index 52c6dbec9c..9e7968f7bf 100644
--- a/libraries/matplotlib/matplotlib.info
+++ b/libraries/matplotlib/matplotlib.info
@@ -5,6 +5,6 @@ DOWNLOAD="http://downloads.sourceforge.net/matplotlib/matplotlib-0.99.1.2.tar.gz
MD5SUM="952e2c992e4a762b8538171f51c9140a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-MAINTAINER="João Felipe Santos"
-EMAIL="joao.eel@gmail.com"
-APPROVED="rworkman"
+MAINTAINER="Serban Udrea"
+EMAIL="S.Udrea@gsi.de"
+APPROVED="pprkut"