summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--academic/rpy2/rpy2.SlackBuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/academic/rpy2/rpy2.SlackBuild b/academic/rpy2/rpy2.SlackBuild
index e31ee651c0..23396b09d6 100644
--- a/academic/rpy2/rpy2.SlackBuild
+++ b/academic/rpy2/rpy2.SlackBuild
@@ -100,7 +100,8 @@ echo "LD_LIBRARY_PATH set to ${LD_LIBRARY_PATH}"
# replace deprecated `python3 setup.py build install --root=$PKG`
# thanks to fourtysixandtwo
-export PYTHONPATH=/opt/python3.9/site-packages/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
python3 -m build --no-isolation
python3 -m installer -d "$PKG" dist/*.whl