summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author M.Dinslage2021-07-26 04:36:33 +0200
committer Robby Workman2021-07-26 04:36:33 +0200
commitf5226a274864d9d8193291809c1db20cc68fdfcb (patch)
treece541044e40bbab94c5714471bbec34880fecf49 /system
parent59c050638c28041bc8220aebbcfb94c7789744c4 (diff)
downloadslackbuilds-f5226a274864d9d8193291809c1db20cc68fdfcb.tar.gz
system/conky: Updated for version 1.12.2.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/conky/README19
-rw-r--r--system/conky/conky-1.10.6-gcc7.patch11
-rw-r--r--system/conky/conky.SlackBuild30
-rw-r--r--system/conky/conky.info10
4 files changed, 29 insertions, 41 deletions
diff --git a/system/conky/README b/system/conky/README
index b7b4733768..67b2345e30 100644
--- a/system/conky/README
+++ b/system/conky/README
@@ -5,25 +5,14 @@ your root desktop or in its own window. Conky has many built-in
objects, as well as the ability to execute programs and scripts, then
display the output from stdout.
-Starting with the 1.10.x branch of conky the conkyrc config files now
-use a lua based syntax. This means that older conkyrc config files
-may not work. Conky does attempt to convert older config scripts
-on the fly but if it doesn't work you can convert your config file
-with the convert.lua script that is provided in the /usr/doc
-directory. It is not guaranteed to work but it should give you a
-good starting point to edit the converted script to make it work.
-If you can't get your script to work then you can install the
-1.9.0 version of conky that is provided here at SBo in the 14.1
-branch.
-
Audacious is disabled by default because it requires libaudclient.
libaudclient is available here at SBo. You can enable audacious
-support the build by passing AUDACIOUS=yes ./conky.SlackBuild.
+support in the build by passing AUDACIOUS=yes ./conky.SlackBuild.
If you are using the binary Nvidia drivers, conky has native support
-for monitoring your video cards hardware. To enable this feature
+for monitoring your video cards hardware. To enable this feature,
you must install the binary drivers using the nvidia_kernel and
nvidia_driver packages available here at SBo, or you can use the
binary run installer provided by Nvidia. Once the driver is
-installed you must also install libxnvctrl, also available here
-at SBo. Then pass NVIDIA=yes to the build script.
+installed, you must install libxnvctrl, also available at SBo.
+Then pass NVIDIA=yes to the build script.
diff --git a/system/conky/conky-1.10.6-gcc7.patch b/system/conky/conky-1.10.6-gcc7.patch
deleted file mode 100644
index dcbc3bc8a5..0000000000
--- a/system/conky/conky-1.10.6-gcc7.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Naur conky-1.10.6.orig/src/luamm.hh conky-1.10.6/src/luamm.hh
---- conky-1.10.6.orig/src/luamm.hh 2016-12-04 16:13:57.000000000 +0100
-+++ conky-1.10.6/src/luamm.hh 2017-05-05 12:44:37.525676651 +0200
-@@ -27,6 +27,7 @@
- #include <mutex>
- #include <exception>
- #include <stdexcept>
-+#include <functional>
- #include <string>
-
- #include <lua.hpp>
diff --git a/system/conky/conky.SlackBuild b/system/conky/conky.SlackBuild
index 938fe02f46..daa6574a3c 100644
--- a/system/conky/conky.SlackBuild
+++ b/system/conky/conky.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for conky
-# Copyright 2016 Matt Dinslage (daedra1980@gmail.com), Springfield, MO, USA
+# Copyright 2021 Matt Dinslage (daedra1980@gmail.com), Springfield, MO, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=conky
-VERSION=${VERSION:-1.10.8}
+VERSION=${VERSION:-1.12.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -97,9 +97,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fix for the newer gcc
-patch -p1 < $CWD/conky-1.10.6-gcc7.patch
-
# fix MANDIR
sed -i 's,share/man/man1,man/man1,g' CMakeLists.txt
@@ -111,8 +108,8 @@ cd build
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
-DDOC_PATH=/usr/doc/$PRGNAM-$VERSION \
- -DMAN_INSTALL_DIR=/usr/man \
-DMAINTAINER_MODE=ON \
+ -DBUILD_DOCS=ON \
-DBUILD_XDBE=ON \
-DBUILD_AUDACIOUS=$audacious \
-DBUILD_NVIDIA=$nvidia \
@@ -120,17 +117,20 @@ cd build
-DBUILD_WLAN=ON \
-DBUILD_RSS=ON \
-DBUILD_WEATHER_METAR=ON \
- -DBUILD_WEATHER_XOAP=ON \
+ -DBUILD_PULSEAUDIO=ON \
-DBUILD_MPD=ON \
-DBUILD_IMLIB2=ON \
-DBUILD_LUA_CAIRO=ON \
-DBUILD_LUA_IMLIB2=ON \
-DCMAKE_BUILD_TYPE=Release ..
- make VERBOSE=1
+ make
make install DESTDIR=$PKG
cd ..
+# Don't ship .a files:
+find $PKG -type f -iname '*.a' -exec rm -rf {} \+
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -142,11 +142,21 @@ mkdir -p $PKG/etc/conky
cp data/conky.conf $PKG/etc/conky/conky.conf.new
cp data/conky_no_x11.conf $PKG/etc/conky/conky_no_x11.conf.new
+# Vim and Nano syntax highlighting files
+mkdir -p $PKG/usr/share/nano
+mkdir -p $PKG/usr/share/vim/vimfiles/{syntax,ftdetect}
+cp extras/vim/syntax/conkyrc.vim $PKG/usr/share/vim/vimfiles/syntax
+cp extras/vim/ftdetect/conkyrc.vim $PKG/usr/share/vim/vimfiles/ftdetect
+cp extras/nano/conky.nanorc $PKG/usr/share/nano/conky.nanorc
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING ChangeLog LICENSE.BSD README.md NEWS TODO \
+cp -a AUTHORS COPYING LICENSE.BSD README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# include copy of convert.lua script for old configs.
+cat extras/convert.lua > $PKG/usr/doc/$PRGNAM-$VERSION/convert.lua
+
# Remove duplicate config files out of the docdir.
rm -r $PKG/usr/doc/$PRGNAM-$VERSION/*.conf
@@ -155,4 +165,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE \ No newline at end of file
diff --git a/system/conky/conky.info b/system/conky/conky.info
index bbe1f2767b..1c3de6e51c 100644
--- a/system/conky/conky.info
+++ b/system/conky/conky.info
@@ -1,10 +1,10 @@
PRGNAM="conky"
-VERSION="1.10.8"
-HOMEPAGE="http://conky.sourceforge.net"
-DOWNLOAD="https://github.com/brndnmtthws/conky/archive/v1.10.8/conky-1.10.8.tar.gz"
-MD5SUM="b02bc92e4b02d4f18259ab3a26c8c5ba"
+VERSION="1.12.2"
+HOMEPAGE="https://github.com/brndnmtthws/conky"
+DOWNLOAD="https://github.com/brndnmtthws/conky/archive/v1.12.2/conky-1.12.2.tar.gz"
+MD5SUM="31b6d5d139d06f2639813bfa87c372bb"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="tolua++ imlib2"
+REQUIRES="lua53 imlib2"
MAINTAINER="M.Dinslage"
EMAIL="daedra1980@gmail.com"