summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Dimitris Zlatanidis2023-06-30 09:10:48 +0200
committer Willy Sudiarto Raharjo2023-07-02 18:21:24 +0200
commit8173b107dfe60a05c67c785fc5ddaa044e7a6666 (patch)
tree5359b601d55c9176562b788e2f3a95a411415fff /system
parent227c320991e042479db8ac3612395388b209f52e (diff)
downloadslackbuilds-8173b107dfe60a05c67c785fc5ddaa044e7a6666.tar.gz
system/slpkg: Updated for version 4.9.1.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/slpkg/doinst.sh4
-rw-r--r--system/slpkg/slpkg.SlackBuild5
-rw-r--r--system/slpkg/slpkg.info8
3 files changed, 7 insertions, 10 deletions
diff --git a/system/slpkg/doinst.sh b/system/slpkg/doinst.sh
index 74029f7a09..ead18dfea4 100644
--- a/system/slpkg/doinst.sh
+++ b/system/slpkg/doinst.sh
@@ -12,7 +12,3 @@ FILES="slpkg repositories blacklist rules"
for file in $FILES; do
config etc/slpkg/$file.toml.new
done
-
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/system/slpkg/slpkg.SlackBuild b/system/slpkg/slpkg.SlackBuild
index 9c2901ba88..08b3ccbe54 100644
--- a/system/slpkg/slpkg.SlackBuild
+++ b/system/slpkg/slpkg.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=slpkg
-VERSION=${VERSION:-4.8.9}
+VERSION=${VERSION:-4.9.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,7 +79,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
# Move executables to the /usr/sbin folder.
mkdir -p $PKG/usr/sbin
diff --git a/system/slpkg/slpkg.info b/system/slpkg/slpkg.info
index 5706a11c41..c3e5761eee 100644
--- a/system/slpkg/slpkg.info
+++ b/system/slpkg/slpkg.info
@@ -1,10 +1,10 @@
PRGNAM="slpkg"
-VERSION="4.8.9"
+VERSION="4.9.1"
HOMEPAGE="https://dslackw.gitlab.io/slpkg"
-DOWNLOAD="https://gitlab.com/dslackw/slpkg/-/archive/4.8.9/slpkg-4.8.9.tar.gz"
-MD5SUM="a5ac5dc3be4d124de3c6fe16c5664059"
+DOWNLOAD="https://gitlab.com/dslackw/slpkg/-/archive/4.9.1/slpkg-4.9.1.tar.gz"
+MD5SUM="88f6b4900de1bb6fd1a96ea40090be01"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="SQLAlchemy python3-pythondialog python3-progress"
+REQUIRES="python3-build SQLAlchemy python3-pythondialog python3-progress"
MAINTAINER="Dimitris Zlatanidis"
EMAIL="d.zlatanidis@gmail.com"