summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Antonio Leal2023-07-08 07:38:44 +0200
committer Willy Sudiarto Raharjo2023-07-08 11:41:53 +0200
commit229d37049a3505e19af38fe800f8fb69280f35b4 (patch)
tree24bfda3e0c134beb2ac0c3a678d2700910607397 /system
parent6854d907e0a02e373ad6b5670f27597d6840aa47 (diff)
downloadslackbuilds-229d37049a3505e19af38fe800f8fb69280f35b4.tar.gz
system/b2: Added (BBC Micro emulator).
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/b2/Makefile.unix.mak.patch11
-rw-r--r--system/b2/README4
-rw-r--r--system/b2/b2.SlackBuild126
-rw-r--r--system/b2/b2.desktop8
-rw-r--r--system/b2/b2.info10
-rw-r--r--system/b2/b2.pngbin0 -> 2619 bytes
-rw-r--r--system/b2/doinst.sh13
-rw-r--r--system/b2/slack-desc19
8 files changed, 191 insertions, 0 deletions
diff --git a/system/b2/Makefile.unix.mak.patch b/system/b2/Makefile.unix.mak.patch
new file mode 100644
index 0000000000..8ef3bf00f2
--- /dev/null
+++ b/system/b2/Makefile.unix.mak.patch
@@ -0,0 +1,11 @@
+--- Makefile.unix.mak. 2023-06-10 11:56:03.000000000 +0100
++++ Makefile.unix.mak 2023-06-21 21:10:15.499776974 +0100
+@@ -52,7 +52,7 @@
+ @echo ---------------------------------------------------------------------------
+ rm -Rf "$(_FOLDER)"
+ mkdir -p "$(_FOLDER)"
+- (cd "$(_FOLDER)" && cmake -G "$(CMAKE_TYPE)" $(CMAKE_DEFINES) -DCMAKE_BUILD_TYPE=$(BUILD) $(if $(SANITIZER),-DSANITIZE_$(SANITIZER)=On) ../..) || $(if $(SANITIZER),rm -Rf "$(_FOLDER)",false)
++ (cd "$(_FOLDER)" && cmake -G "$(CMAKE_TYPE)" $(CMAKE_DEFINES) -DCMAKE_BUILD_TYPE=$(BUILD) $(if $(SANITIZER),-DSANITIZE_$(SANITIZER)=Off) ../..) || $(if $(SANITIZER),rm -Rf "$(_FOLDER)",false)
+
+ .PHONY:buildall
+ buildall:
diff --git a/system/b2/README b/system/b2/README
new file mode 100644
index 0000000000..b245aa0dd0
--- /dev/null
+++ b/system/b2/README
@@ -0,0 +1,4 @@
+b2 is a cross-platform BBC Micro emulator. Use your Windows/Linux PC or
+macOS computer to play your old BBC games or develop new BBC software.
+
+more info at https://github.com/tom-seddon/b2
diff --git a/system/b2/b2.SlackBuild b/system/b2/b2.SlackBuild
new file mode 100644
index 0000000000..36a3e0bd99
--- /dev/null
+++ b/system/b2/b2.SlackBuild
@@ -0,0 +1,126 @@
+#!/bin/bash
+
+# Slackware build script for b2 BBC Micro Emulator
+
+# Copyright 2023 Antonio Leal, Porto Salvo, Oeiras, Portugal
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=b2
+VERSION=${VERSION:-20230115_000739_a0a2fe9}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+TARBALL=${TARBALL:-b2-20230115-000739-a0a2fe9}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+
+cd $TMP
+rm -rf $TARBALL
+tar xvfz $CWD/$TARBALL.tar.gz
+cd $TARBALL
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+#Disable sanitizers, build plain old Release
+patch Makefile.unix.mak $CWD/Makefile.unix.mak.patch
+make init
+cd build/r.linux
+ninja
+cd ../..
+
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
+
+mkdir -p $PKG/opt/b2
+install -Dsv -m 0755 build/r.linux/src/b2/b2 $PKG/opt/b2/b2
+cp -avxu build/r.linux/src/b2/assets $PKG/opt/b2
+
+mkdir -p $PKG/usr/share/pixmaps
+cp $CWD/b2.png $PKG/usr/share/pixmaps
+mkdir -p $PKG/usr/share/applications
+cp $CWD/b2.desktop $PKG/usr/share/applications
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cp doc/BeebLink.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp doc/Command-Line.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp doc/File-Association.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp doc/Overview.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp doc/b2_notes.org $PKG/usr/doc/$PRGNAM-$VERSION
+cp doc/other-code-notes.md $PKG/usr/doc/$PRGNAM-$VERSION
+
+# Symlinks
+mkdir -p $PKG/usr/bin/
+( cd $PKG/usr/bin ; rm -rf b2 )
+( cd $PKG/usr/bin ; ln -sf ../../opt/b2/b2 b2 )
+mkdir -p $PKG/opt/
+( cd $PKG/opt/b2 ; rm -rf doc )
+( cd $PKG/opt/b2 ; ln -sf ../../usr/doc/$PRGNAM-$VERSION doc )
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/b2/b2.desktop b/system/b2/b2.desktop
new file mode 100644
index 0000000000..4ba6703d99
--- /dev/null
+++ b/system/b2/b2.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=b2
+Comment=BBC Microcomputer Emulator
+Exec=/opt/b2/b2
+Icon=/usr/share/pixmaps/b2.png
+Terminal=false
+Type=Application
+Categories=System;Emulator;
diff --git a/system/b2/b2.info b/system/b2/b2.info
new file mode 100644
index 0000000000..ed5010aa08
--- /dev/null
+++ b/system/b2/b2.info
@@ -0,0 +1,10 @@
+PRGNAM="b2"
+VERSION="20230115_000739_a0a2fe9"
+HOMEPAGE="https://github.com/tom-seddon/b2"
+DOWNLOAD="https://github.com/antonioleal/slackbuilds/raw/main/b2/b2-20230115-000739-a0a2fe9.tar.gz"
+MD5SUM="11a6c3f9431777d8e85ab9e71da5db56"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="uuid"
+MAINTAINER="Antonio Leal"
+EMAIL="antonioleal@yahoo.com"
diff --git a/system/b2/b2.png b/system/b2/b2.png
new file mode 100644
index 0000000000..0fba2279ed
--- /dev/null
+++ b/system/b2/b2.png
Binary files differ
diff --git a/system/b2/doinst.sh b/system/b2/doinst.sh
new file mode 100644
index 0000000000..aea0f894eb
--- /dev/null
+++ b/system/b2/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/system/b2/slack-desc b/system/b2/slack-desc
new file mode 100644
index 0000000000..3282c1cbcf
--- /dev/null
+++ b/system/b2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+b2: b2 (BBC Microcomputer Emulator)
+b2:
+b2: b2 is a cross-platform BBC Micro emulator. Use your Windows/Linux PC
+b2: or macOS computer to play your old BBC games or develop new BBC
+b2: software.
+b2:
+b2: more info at https://github.com/tom-seddon/b2
+b2:
+b2:
+b2:
+b2: