summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Mohammad Etemaddar2015-11-27 16:53:52 +0100
committer Willy Sudiarto Raharjo2015-11-28 01:25:59 +0100
commit421592ca62bf52fb641b32424eb7ed18f7c38932 (patch)
tree4b1e7702ff8c0de693fe2445eae1f149869fe95c /system
parent328460ccc601258c23eb96d5794e9624e8209ac3 (diff)
downloadslackbuilds-421592ca62bf52fb641b32424eb7ed18f7c38932.tar.gz
system/multibootusb: Added (Install live linux on a USB disk).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/multibootusb/README11
-rw-r--r--system/multibootusb/doinst.sh3
-rw-r--r--system/multibootusb/multibootusb.SlackBuild86
-rw-r--r--system/multibootusb/multibootusb.info10
-rw-r--r--system/multibootusb/slack-desc19
5 files changed, 129 insertions, 0 deletions
diff --git a/system/multibootusb/README b/system/multibootusb/README
new file mode 100644
index 0000000000..1c4dfb3027
--- /dev/null
+++ b/system/multibootusb/README
@@ -0,0 +1,11 @@
+multibootusb (Install multiple live linux on a USB disk)
+
+MultiBootUSB allows you to install multiple live linux on a USB disk
+non destructively and option to uninstall distros.
+
+User can get the distro's all available *default* boot options during
+distro's installation.
+
+Syslinux is used as default boot loader for making USB bootable.
+
+- You also need QEMU in order to use it within multibootusb.
diff --git a/system/multibootusb/doinst.sh b/system/multibootusb/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/system/multibootusb/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/system/multibootusb/multibootusb.SlackBuild b/system/multibootusb/multibootusb.SlackBuild
new file mode 100644
index 0000000000..1c438447fc
--- /dev/null
+++ b/system/multibootusb/multibootusb.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for multibootusb
+
+# Copyright 2015 Mohammad Etemaddar Iran
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=multibootusb
+VERSION=${VERSION:-7.5.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/v$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG LICENSE.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/multibootusb/multibootusb.info b/system/multibootusb/multibootusb.info
new file mode 100644
index 0000000000..ac393348ba
--- /dev/null
+++ b/system/multibootusb/multibootusb.info
@@ -0,0 +1,10 @@
+PRGNAM="multibootusb"
+VERSION="7.5.0"
+HOMEPAGE="http://multibootusb.org/"
+DOWNLOAD="https://github.com/mbusb/multibootusb/archive/v7.5.0.tar.gz"
+MD5SUM="d3c13cdc308486f2966ffc60b211ea70"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Mohammad Etemaddar"
+EMAIL="mohammad.etemaddar@gmail.com"
diff --git a/system/multibootusb/slack-desc b/system/multibootusb/slack-desc
new file mode 100644
index 0000000000..c3dcb78871
--- /dev/null
+++ b/system/multibootusb/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+multibootusb: multibootusb (Install multiple live linux on a USB disk)
+multibootusb:
+multibootusb: MultiBootUSB allows you to install multiple live linux on a USB disk
+multibootusb: non destructively and option to uninstall distros.
+multibootusb:
+multibootusb: User can get the distro's all available *default* boot options during
+multibootusb: distro's installation.
+multibootusb: Syslinux is used as default boot loader for making USB bootable.
+multibootusb: - You also need QEMU in order to use it within multibootusb.
+multibootusb:
+multibootusb: Homepage: http://multibootusb.org/