summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Ryan P.C. McQuen2014-08-10 19:08:49 +0200
committer Willy Sudiarto Raharjo2014-08-15 18:21:21 +0200
commit1916c02cb6af9777f0ff40fd9192ef1d5b977b04 (patch)
tree15c213ed3f8615468c42dabc027efcd1aeae4ade /system
parent48e3666c679d5b0411c52ec7d7648a7ebc714217 (diff)
downloadslackbuilds-1916c02cb6af9777f0ff40fd9192ef1d5b977b04.tar.gz
system/slim: Updated for version 1.3.6 + new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/slim/CMakeLists.txt.patch14
-rw-r--r--system/slim/slim.SlackBuild31
-rw-r--r--system/slim/slim.conf.patch10
-rw-r--r--system/slim/slim.info10
4 files changed, 44 insertions, 21 deletions
diff --git a/system/slim/CMakeLists.txt.patch b/system/slim/CMakeLists.txt.patch
new file mode 100644
index 0000000000..9a29e6c2d7
--- /dev/null
+++ b/system/slim/CMakeLists.txt.patch
@@ -0,0 +1,14 @@
+--- CMakeLists.txt.orig 2014-08-08 07:24:01.864876514 -0700
++++ CMakeLists.txt 2014-08-08 07:24:51.980873088 -0700
+@@ -221,7 +221,10 @@
+ ####### install
+ # slim
+ install(TARGETS slim RUNTIME DESTINATION bin)
+-install(TARGETS slimlock RUNTIME DESTINATION bin)
++## we have to comment this out or else
++## build will fail on slackware as pam
++## is required for slimlock
++#install(TARGETS slimlock RUNTIME DESTINATION bin)
+
+ if (BUILD_SHARED_LIBS)
+ set_target_properties(libslim PROPERTIES
diff --git a/system/slim/slim.SlackBuild b/system/slim/slim.SlackBuild
index 14a909e48e..7c434e6a99 100644
--- a/system/slim/slim.SlackBuild
+++ b/system/slim/slim.SlackBuild
@@ -2,6 +2,8 @@
# Slackware build script for SLiM
+# Ryan P.C. McQuen | Everett, WA | ryan.q@linux.com
+
# Copyright 2006 Martin Lefebvre <dadexter@gmail.com>
# Copyright 2007-2009 Frank Caraballo <fecaraballo{at}gmail{dot}com>
# Copyright 2010,2013 Niels Horn, Rio de Janeiro, Brazil
@@ -24,10 +26,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# revision date: 2013/03/30
-
PRGNAM=slim
-VERSION=${VERSION:-1.3.5}
+VERSION=${VERSION:-1.3.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -68,16 +68,19 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Correct the path used for suspend:
patch -p0 < $CWD/slim.conf.patch
+# disable slimlock build
+patch -p0 < $CWD/CMakeLists.txt.patch
# Fix location of man-pages
sed "s/share\/man/man/" -i CMakeLists.txt
+sed -i "s/DESTINATION lib/DESTINATION lib${LIBDIRSUFFIX}/" CMakeLists.txt
mkdir -p build
cd build
@@ -85,6 +88,7 @@ cd build
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_CONSOLEKIT=yes \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
@@ -103,15 +107,20 @@ cat $CWD/slim.logrotate > $PKG/etc/logrotate.d/slim.new
# Kill the incorrectly-placed (and useless anyway) systemd stuff
rm -rf $PKG/usr/usr
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+# Kill systemd stuff
+rm -rf $PKG/lib
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+# Remove slimlock as we don't build it
+rm $PKG/usr/man/man1/slimlock.1.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- ChangeLog COPYING INSTALL README THEMES TODO xinitrc.sample \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog COPYING INSTALL README THEMES TODO xinitrc.sample $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/README.SLACKWARE > $PKG/usr/doc/$PRGNAM-$VERSION/README.SLACKWARE
diff --git a/system/slim/slim.conf.patch b/system/slim/slim.conf.patch
index e2edc801ba..88d47513c1 100644
--- a/system/slim/slim.conf.patch
+++ b/system/slim/slim.conf.patch
@@ -1,10 +1,10 @@
---- slim.conf.orig 2008-12-05 13:47:44.512494201 -0600
-+++ slim.conf 2008-12-05 13:51:51.449743538 -0600
-@@ -8,7 +8,7 @@
- halt_cmd /sbin/shutdown -h now
+--- slim.conf.orig 2014-08-07 21:04:23.591900466 -0700
++++ slim.conf 2014-08-07 21:05:44.455894937 -0700
+@@ -9,6 +9,8 @@
reboot_cmd /sbin/shutdown -r now
console_cmd /usr/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue; exec /bin/login"
--#suspend_cmd /usr/sbin/suspend
+ #suspend_cmd /usr/sbin/suspend
++## slackware suspend command
+suspend_cmd /usr/sbin/pm-suspend
# Full path to the xauth binary
diff --git a/system/slim/slim.info b/system/slim/slim.info
index 7cdbd95d5c..6148a46f07 100644
--- a/system/slim/slim.info
+++ b/system/slim/slim.info
@@ -1,10 +1,10 @@
PRGNAM="slim"
-VERSION="1.3.5"
+VERSION="1.3.6"
HOMEPAGE="http://sourceforge.net/projects/slim.berlios/"
-DOWNLOAD="http://sourceforge.net/projects/slim.berlios/files/slim-1.3.5.tar.gz"
-MD5SUM="1153e6993f9c9333e4cf745411d03472"
+DOWNLOAD="http://sourceforge.net/projects/slim.berlios/files/slim-1.3.6.tar.gz"
+MD5SUM="d40d256394f9ef34cef34d2aa9cb52e6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Niels Horn"
-EMAIL="niels.horn@gmail.com"
+MAINTAINER="Ryan P.C. McQuen"
+EMAIL="ryan.q@linux.com"