summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-24 02:00:56 +0100
committer Erik Hanson2014-01-30 06:21:12 +0100
commit466aca53daff2223bc988fbb6439adf7e6ddd8f2 (patch)
tree9f0890ffc3ad865dca20a13439c1948d06ab12c2 /system
parentfc12c552188e358b6c0b8f747e32369cfce66688 (diff)
downloadslackbuilds-466aca53daff2223bc988fbb6439adf7e6ddd8f2.tar.gz
system/sentimental-skk: Added (Japanese Input Method SKK).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/sentimental-skk/README8
-rw-r--r--system/sentimental-skk/sentimental-skk.SlackBuild85
-rw-r--r--system/sentimental-skk/sentimental-skk.info10
-rw-r--r--system/sentimental-skk/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/system/sentimental-skk/README b/system/sentimental-skk/README
new file mode 100644
index 0000000000..85d8cfb6af
--- /dev/null
+++ b/system/sentimental-skk/README
@@ -0,0 +1,8 @@
+Sentimental SKK
+
+This program provides Simple Kana Kanji conversion (SKK) input method service
+to your terminal.
+
+It depends on "Canossa"(https://github.com/saitoha/canossa), which is an
+off-screen terminal emulation service, "Canossa" makes application enable
+to restore specified screen region on demand!!
diff --git a/system/sentimental-skk/sentimental-skk.SlackBuild b/system/sentimental-skk/sentimental-skk.SlackBuild
new file mode 100644
index 0000000000..62730b08f8
--- /dev/null
+++ b/system/sentimental-skk/sentimental-skk.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for sentimental-skk
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=sentimental-skk
+VERSION=${VERSION:-0.0.136}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst COPYING PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/sentimental-skk/sentimental-skk.info b/system/sentimental-skk/sentimental-skk.info
new file mode 100644
index 0000000000..952aa421e5
--- /dev/null
+++ b/system/sentimental-skk/sentimental-skk.info
@@ -0,0 +1,10 @@
+PRGNAM="sentimental-skk"
+VERSION="0.0.136"
+HOMEPAGE="https://github.com/saitoha/sentimental-skk"
+DOWNLOAD="https://pypi.python.org/packages/source/s/sentimental-skk/sentimental-skk-0.0.136.tar.gz"
+MD5SUM="af6e31e7a27844db914b3f5f38ffdbcf"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/system/sentimental-skk/slack-desc b/system/sentimental-skk/slack-desc
new file mode 100644
index 0000000000..7eecdc6742
--- /dev/null
+++ b/system/sentimental-skk/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+sentimental-skk: sentimental-skk (Japanese Input Method SKK on your terminal)
+sentimental-skk:
+sentimental-skk: This program provides Simple Kana Kanji conversion (SKK) input
+sentimental-skk: method service to your terminal. It depends on "Canossa"
+sentimental-skk: which is an off-screen terminal emulation service, "Canossa"
+sentimental-skk: makes application enable to restore specified screen region on
+sentimental-skk: demand!! So this SKK service can provide cool popup feature.
+sentimental-skk:
+sentimental-skk: Homepage: https://github.com/saitoha/sentimental-skk
+sentimental-skk:
+sentimental-skk: