summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-27 16:59:05 +0100
committer Erik Hanson2014-01-30 06:21:17 +0100
commit238f0796c46ca125500f438ac4e4bcbb54a02219 (patch)
treedeee16983a32b0c61fecdcf70909a42d4b9ca0d6 /system
parentfdf7b09e8c70ee266fc9f7233e2300ff19abad3a (diff)
downloadslackbuilds-238f0796c46ca125500f438ac4e4bcbb54a02219.tar.gz
system/barman: Added (Backup and Recovery Manager for PostgreSQL).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/barman/README11
-rw-r--r--system/barman/barman.SlackBuild89
-rw-r--r--system/barman/barman.info10
-rw-r--r--system/barman/slack-desc19
4 files changed, 129 insertions, 0 deletions
diff --git a/system/barman/README b/system/barman/README
new file mode 100644
index 0000000000..a10da6e421
--- /dev/null
+++ b/system/barman/README
@@ -0,0 +1,11 @@
+Backup and Recovery Manager for PostgreSQL Tutorial.
+
+Barman (backup and recovery manager) is an administration tool for
+disaster recovery of PostgreSQL servers written in Python. Barman can
+perform remote backups of multiple servers in business critical
+environments, and helps DBAs during the recovery phase.
+
+Barman's most wanted features include: backup catalogues, retention
+policies, remote recovery, archiving and compression of WAL files and
+of backups. Barman is written and maintained by PostgreSQL
+professionals 2ndQuadrant.
diff --git a/system/barman/barman.SlackBuild b/system/barman/barman.SlackBuild
new file mode 100644
index 0000000000..7695aa9e96
--- /dev/null
+++ b/system/barman/barman.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for barman
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=barman
+VERSION=${VERSION:-1.2.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mv $PKG/usr/share/man $PKG/usr
+find $PKG/usr/man -type f -name "*.?" -exec gzip -9f {} \;
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS ChangeLog LICENSE INSTALL NEWS README PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/barman/barman.info b/system/barman/barman.info
new file mode 100644
index 0000000000..d0db38d039
--- /dev/null
+++ b/system/barman/barman.info
@@ -0,0 +1,10 @@
+PRGNAM="barman"
+VERSION="1.2.3"
+HOMEPAGE="http://www.pgbarman.org/"
+DOWNLOAD="http://sourceforge.net/projects/pgbarman/files/1.2.3/barman-1.2.3.tar.gz"
+MD5SUM="5348cf3ea707b43f8a98061d0d257f2d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="psycopg2 argh python-dateutil argcomplete"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/system/barman/slack-desc b/system/barman/slack-desc
new file mode 100644
index 0000000000..1b2187ed11
--- /dev/null
+++ b/system/barman/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+barman: barman (Backup and Recovery Manager for PostgreSQL)
+barman:
+barman: Barman (backup and recovery manager) is an administration tool for
+barman: disaster recovery of PostgreSQL servers written in Python. It allows
+barman: to perform remote backups of multiple servers in business critical
+barman: environments and help DBAs during the recovery phase. Barman's most
+barman: wanted features include backup catalogs, retention policies, remote
+barman: recovery, archiving and compression of WAL files and backups. Barman
+barman: is written and maintained by PostgreSQL professionals 2ndQuadrant.
+barman:
+barman: Homepage: http://www.pgbarman.org/