summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author ponce2011-12-28 12:49:04 +0100
committer Robby Workman2011-12-31 07:24:40 +0100
commit894401804b6875fe952c37fe787b7f22a54cd983 (patch)
tree58fde55bf97f0d1c46ba320613fd9b288bf26c14 /system
parentac21e61dff501595e373ee86cab33adc860e23f5 (diff)
downloadslackbuilds-894401804b6875fe952c37fe787b7f22a54cd983.tar.gz
system/gksu-polkit: Added (gksu using policykit)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/gksu-polkit/README8
-rw-r--r--system/gksu-polkit/gksu-polkit.SlackBuild84
-rw-r--r--system/gksu-polkit/gksu-polkit.info10
-rw-r--r--system/gksu-polkit/slack-desc19
4 files changed, 121 insertions, 0 deletions
diff --git a/system/gksu-polkit/README b/system/gksu-polkit/README
new file mode 100644
index 0000000000..48a47e727f
--- /dev/null
+++ b/system/gksu-polkit/README
@@ -0,0 +1,8 @@
+gksu-polkit (gksu through policykit)
+
+gksu is a library and application used to ask the user for passwords
+to run programs as root. It is not a good option now that we have
+PolicyKit. This new version will provide similar functionality to
+cover applications which still haven't been patched to use PolicyKit.
+
+This depends on libgee.
diff --git a/system/gksu-polkit/gksu-polkit.SlackBuild b/system/gksu-polkit/gksu-polkit.SlackBuild
new file mode 100644
index 0000000000..e1b1b1c5ec
--- /dev/null
+++ b/system/gksu-polkit/gksu-polkit.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# Slackware build script for gksu-polkit
+# Written by ponce <matteo.bernardini@gmail.com>
+
+PRGNAM=gksu-polkit
+VERSION=${VERSION:-20100909_d7e3160}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+DOCS="AUTHORS COPYING ChangeLog HACKING README THANKS TODO"
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# respect our $CFLAGS
+sed -i "s|-g -O2|$SLKCFLAGS|" aclocal.m4
+sed -i "s|-g -O2 -Wall|$SLKCFLAGS|" */Makefile.am
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./autogen.sh \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --enable-static=no \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/gksu-polkit/gksu-polkit.info b/system/gksu-polkit/gksu-polkit.info
new file mode 100644
index 0000000000..95ba49401a
--- /dev/null
+++ b/system/gksu-polkit/gksu-polkit.info
@@ -0,0 +1,10 @@
+PRGNAM="gksu-polkit"
+VERSION="20100909_d7e3160"
+HOMEPAGE="http://live.gnome.org/gksu"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/gksu-polkit-20100909_d7e3160.tar.xz"
+MD5SUM="6c0f658eb511482be2ee16a301d1f63b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="ponce"
+EMAIL="matteo.bernardini@gmail.com"
+APPROVED="Erik Hanson"
diff --git a/system/gksu-polkit/slack-desc b/system/gksu-polkit/slack-desc
new file mode 100644
index 0000000000..0d3f6f6f6f
--- /dev/null
+++ b/system/gksu-polkit/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gksu-polkit: gksu-polkit (gksu using policykit)
+gksu-polkit:
+gksu-polkit: gksu is a library and application used to ask the user for passwords
+gksu-polkit: to run programs as root. It is not a good option now that we have
+gksu-polkit: PolicyKit. This new version will provide similar functionality to
+gksu-polkit: cover applications which still haven't been patched to use PolicyKit.
+gksu-polkit:
+gksu-polkit: homepage: http://live.gnome.org/gksu
+gksu-polkit:
+gksu-polkit:
+gksu-polkit: