summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Pierre Cazenave2010-12-13 16:31:12 +0100
committer Erik Hanson2010-12-17 14:56:24 +0100
commitc1a0adf130a77c22bef182826dd581de9f9c0a4a (patch)
treec9f7bd6cef6e9d917adae2c56ea818ff68a0fe9b /system
parent94f19b27e86834fa69623c8ffaa418945e31bf71 (diff)
downloadslackbuilds-c1a0adf130a77c22bef182826dd581de9f9c0a4a.tar.gz
system/trash-cli: Added (command line interface to the FreeDesktop.org trashcan)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/trash-cli/README1
-rw-r--r--system/trash-cli/slack-desc19
-rw-r--r--system/trash-cli/trash-cli.SlackBuild83
-rw-r--r--system/trash-cli/trash-cli.info10
4 files changed, 113 insertions, 0 deletions
diff --git a/system/trash-cli/README b/system/trash-cli/README
new file mode 100644
index 0000000000..409df44aa9
--- /dev/null
+++ b/system/trash-cli/README
@@ -0,0 +1 @@
+trash-cli is a command line interface to the FreeDesktop.org trashcan.
diff --git a/system/trash-cli/slack-desc b/system/trash-cli/slack-desc
new file mode 100644
index 0000000000..d435bffedb
--- /dev/null
+++ b/system/trash-cli/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+trash-cli: trash-cli (command line interface to the FreeDesktop.org trashcan)
+trash-cli:
+trash-cli: * Command line interface compatible with the rm command. You can
+trash-cli: alias rm with trash.
+trash-cli: * Remembers original path, deletion time and file permissions of
+trash-cli: each trashed file.
+trash-cli: * Compatible with the KDE trash.
+trash-cli: * Implements the FreeDesktop.org Trash Specification
+trash-cli: * Works with volume other than the home volume (e.g. USB pen or
+trash-cli: another partition).
+trash-cli:
diff --git a/system/trash-cli/trash-cli.SlackBuild b/system/trash-cli/trash-cli.SlackBuild
new file mode 100644
index 0000000000..e5fe245430
--- /dev/null
+++ b/system/trash-cli/trash-cli.SlackBuild
@@ -0,0 +1,83 @@
+#!/bin/sh
+
+# Slackware build script for the trash-cli utils.
+#
+# Copyright 2010 Pierre Cazenave <pwcazenave {at} gmail [dot] com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=trash-cli
+VERSION=${VERSION:-0.11.3-r315}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py install --root=$PKG
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING HISTORY.txt INSTALL.txt PKG-INFO README.txt THANKS \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README$TAG
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/trash-cli/trash-cli.info b/system/trash-cli/trash-cli.info
new file mode 100644
index 0000000000..fdc3a37bff
--- /dev/null
+++ b/system/trash-cli/trash-cli.info
@@ -0,0 +1,10 @@
+PRGNAM="trash-cli"
+VERSION="0.11.3-r315"
+HOMEPAGE="https://code.google.com/p/trash-cli/"
+DOWNLOAD="http://trash-cli.googlecode.com/files/trash-cli-0.11.3-r315.tar.gz"
+MD5SUM="00654c149108fc4c522b5b008e9b8468"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Pierre Cazenave"
+EMAIL="pwcazenave <at> gmail {dot} com"
+APPROVED="Erik Hanson"