summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author crocket2010-10-20 06:40:00 +0200
committer Erik Hanson2010-10-20 17:50:24 +0200
commitcfa48edbacb46588e2771e8fb2c3e3669e2d139b (patch)
tree39740c63f23025d54c81fd6fe0e2d84dadc44937 /system
parent0ae61b19ec2c193103fe9cd6e6e0ae30e7016382 (diff)
downloadslackbuilds-cfa48edbacb46588e2771e8fb2c3e3669e2d139b.tar.gz
system/unalz: Added (decompression utility for alz)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/unalz/README9
-rw-r--r--system/unalz/slack-desc19
-rw-r--r--system/unalz/unalz.SlackBuild78
-rw-r--r--system/unalz/unalz.info10
-rw-r--r--system/unalz/unalz_makefile.diff13
5 files changed, 129 insertions, 0 deletions
diff --git a/system/unalz/README b/system/unalz/README
new file mode 100644
index 0000000000..65d028dd0f
--- /dev/null
+++ b/system/unalz/README
@@ -0,0 +1,9 @@
+unalz (A decompression utility for alz)
+
+unalz is an open source program that can decompress alz files.
+alz is an archive format developed for alzip.
+Alzip is an archiver that can compress/decompress in such formats
+as zip, rar, alz, and etc.
+
+Here is a tip : UHC is the same as CP949, and CP949 contains the
+EUCKR character set.
diff --git a/system/unalz/slack-desc b/system/unalz/slack-desc
new file mode 100644
index 0000000000..6f2b643677
--- /dev/null
+++ b/system/unalz/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+unalz: unalz (decompression utility for alz)
+unalz:
+unalz: unalz is an open source program that can decompress alz files.
+unalz: alz is an archive format developed for alzip.
+unalz: Alzip is an archiver that can compress/decompress in such formats
+unalz: as zip, rar, alz, and etc.
+unalz:
+unalz: Tip: UHC is the same as CP949 and CP949 contains EUCKR charset.
+unalz:
+unalz: Homepage: http://www.kippler.com/win/unalz/
+unalz:
diff --git a/system/unalz/unalz.SlackBuild b/system/unalz/unalz.SlackBuild
new file mode 100644
index 0000000000..defc3a1af1
--- /dev/null
+++ b/system/unalz/unalz.SlackBuild
@@ -0,0 +1,78 @@
+#!/bin/sh
+
+# Slackware build script for unalz
+
+# Written by crocket ( crockabiscuit@yahoo.com )
+
+PRGNAM=unalz
+VERSION=${VERSION:-0.65}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tgz
+mv $PRGNAM $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Apply a makefile patch.
+patch -p1 < $CWD/unalz_makefile.diff
+
+# convert the encoding from CP949 to UTF8
+# CP949 == UHC, and CP949 contains EUCKR character set.
+# So using CP949 or UHC takes care of texts in EUCKR encoding
+find . -type f -exec iconv --from-code=CP949 --to-code=UTF8 {} --output={}_tmp \; \
+ -exec mv {}_tmp {} \;
+
+make linux-utf8
+make install DESTDIR=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a readme.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/unalz/unalz.info b/system/unalz/unalz.info
new file mode 100644
index 0000000000..7a6230efd8
--- /dev/null
+++ b/system/unalz/unalz.info
@@ -0,0 +1,10 @@
+PRGNAM="unalz"
+VERSION="0.65"
+HOMEPAGE="http://www.kippler.com/win/unalz/"
+DOWNLOAD="http://www.kippler.com/win/unalz/unalz-0.65.tgz"
+MD5SUM="e4db2c4e3c8f6f5ee414b68bc55288e5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="crocket"
+EMAIL="crockabiscuit@yahoo.com"
+APPROVED="rworkman"
diff --git a/system/unalz/unalz_makefile.diff b/system/unalz/unalz_makefile.diff
new file mode 100644
index 0000000000..dd6e199e47
--- /dev/null
+++ b/system/unalz/unalz_makefile.diff
@@ -0,0 +1,13 @@
+diff -Naur unalz/Makefile unalz-patched/Makefile
+--- unalz/Makefile 2009-01-20 10:42:59.000000000 +0900
++++ unalz-patched/Makefile 2010-10-03 22:08:17.862000012 +0900
+@@ -38,7 +38,8 @@
+ $(CPP) $(OBJ) $(LDFLAGS) -o $(BIN)
+
+ install:
+- cp unalz /usr/local/bin/
++ mkdir -p $(DESTDIR)/usr/bin
++ cp unalz $(DESTDIR)/usr/bin
+
+ clean:
+ rm -f $(OBJ) $(BIN)