summaryrefslogtreecommitdiffstats
path: root/system/tiger/tiger.SlackBuild
diff options
context:
space:
mode:
author pyllyukko2013-06-05 18:03:18 +0200
committer dsomero2013-06-05 18:03:18 +0200
commit52ef78e897bb46d93458d88762773384a5aa986e (patch)
tree54c12369337f1a3ed1edd80d30f4a3f226000d29 /system/tiger/tiger.SlackBuild
parentc515acb0700c884d6e53d0b20ae186842728f821 (diff)
downloadslackbuilds-52ef78e897bb46d93458d88762773384a5aa986e.tar.gz
system/tiger: Updated with a few bug fixing patches.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'system/tiger/tiger.SlackBuild')
-rw-r--r--system/tiger/tiger.SlackBuild21
1 files changed, 18 insertions, 3 deletions
diff --git a/system/tiger/tiger.SlackBuild b/system/tiger/tiger.SlackBuild
index a5db73dcbe..19639e24c8 100644
--- a/system/tiger/tiger.SlackBuild
+++ b/system/tiger/tiger.SlackBuild
@@ -11,7 +11,7 @@
PRGNAM=tiger
VERSION=${VERSION:-3.2.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -41,7 +41,7 @@ else
LIBDIRSUFFIX=""
fi
-set -e # Exit on most errors
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -79,6 +79,20 @@ find . \
# The build errs on this
# see http://cvs.savannah.gnu.org/viewvc/tiger/tiger/util/genmsgidx?r1=1.6&r2=1.7
patch --verbose -p1 < $CWD/patches/tiger-3.2.3-build-fix.diff
+# fix bug #7186 & #7675
+# see https://savannah.nongnu.org/patch/?7675
+patch --verbose -p1 < $CWD/patches/zappasswd-3.2.3.patch
+# fix bug #33969
+patch --verbose -p1 < $CWD/patches/mkfilelst.patch
+# fix bug #34028
+patch --verbose -p1 < $CWD/patches/check_signatures.patch
+# see https://savannah.nongnu.org/patch/index.php?7859
+patch --verbose -p1 < $CWD/patches/tiger-aide.patch
+# fix bug #37517
+patch --verbose -p1 < $CWD/patches/tiger-makefile.patch
+# add support for ext4 in the check_rootdir script
+# see http://git.savannah.gnu.org/cgit/tiger.git/commit/?id=9a030129ceceba715dff801f8229e66de62a8083
+patch --verbose -p1 < $CWD/patches/9a030129ceceba715dff801f8229e66de62a8083.patch
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS"
@@ -104,7 +118,7 @@ install -D -m 0640 $CWD/config/tiger.ignore $PKG/etc/tiger/tiger.ignore.new
install -D -m 0640 $CWD/config/tiger.default $PKG/etc/default/tiger.new
# From the .spec: 3.- This should be done by the Makefile, grumble...
-install -D -m 0644 version.h $PKG/usr/lib/tiger/version.h
+install -D -m 0644 version.h $PKG/usr/libexec/tiger/version.h
# Remove unnecesary stuff
( cd $PKG
@@ -127,6 +141,7 @@ cp -a [A-Z][A-Z]* site-* tigerrc* \
$PKG/usr/doc/$PRGNAM-$VERSION
cp -a other/cert-usc20.txt contrib/fix_tiger_GROUPS.sh audit \
$PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/README.SLACKWARE > $PKG/usr/doc/$PRGNAM-$VERSION/README.SLACKWARE
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
cp $PKG/usr/libexec/tiger/html/*.html $PKG/usr/doc/$PRGNAM-$VERSION/html